Liberty Lite Charging Case LEDs not turning on. Case not working?

Hi all,

Got my Liberty Lite’s in the mail today and noticed that the LED’s wont turn on on the charging case. Additionally, the headphones wont turn off/on when putting them in/out of the charging case. It feels as if the charging case is completely not functional. The headphones themselves work fine but the case seems not to be working.I have removed the plastic coverings and tried multiple power sources. Am I missing something here?

Hey Mike, can you please be more specific?

I had this happen to me. I reached out to Anker Support.

They will want to confirm that you removed the plastic from underneath each bud. Also I had issues where the only way they would charge is if the case is fully flat and the earbuds are placed inside. Sometimes i’d even have to jiggle them in the case to get the charging leds to pop on. Good luck.

1 Like

Hmmm. Yeah I just took them out of the box and have not had the LED’s turn on even once. It seems that they don’t work at all. Plugging it in also doesnt turn on the LED’s. I’ve tried jiggling the buds as well but to no avail. I just reached out to support as well but I was wondering if there was another answer to the problem.

Since you just got these, please plug them in and leave them to charge overnight… Sometimes they ship with a nominal charge, but given how cold it has been depending where you live they may not have any charge. Plugging then in will take some time for the light to turn on if it is completely dead. So by letting it stay plugged in and charge ivernight it will have a chance to do it’s thing. Once the case gets charged the earbuds themselves will start to charge


Hi, I left them in overnight and there’s been no change. Support got back to me saying that they were likely faulty. Thank you everyone for your help!

1 Like