Liberty Air 2 has no sound when connected to Fire TV cube

I have a pair of liberty air 2 headphones. I’ve had them connected to my Amazon Fire TV cube for months and they worked well. A few days ago they stopped producing any sound when connected to the fire TV cube. The pair with the Fire TV, but there is no audio. If I unpair them, the Fire TV cube produces normal audio. As soon as I pair the headphones, the audio stops from the cube but there is no sound from the headphones. It’s almost as if they are muted, but from what I understand there is no mute function on these headphones. Any suggestion? I’ve updated to the latest firmware, but no luck.

Have you tried to connect the earbuds to other devices?
Have you tried a reset and a reconnection?

Did the Fire TV cube recently have an upgrade?

I would pair the Air 2 to your phone or laptop to make sure that the air 2s are working first. If not, you know it is the earbuds. If they do have sound then you will know that it may be the cube. As a last test I would try to pair a different pair of similar earbuds to see if it is just with the air 2 and not all devices.

Try to “forget” device and pair again