Liberty Air 2 firmware update issue

Hey I have purchased a liberty air 2 recently and was trying to update the firmware of the buds from 4.08 to 4.18. But due to some weird reason it is not updating I have tried all the methods. Reinstalling the app,resetting the buds, restarting the phone etc.
It would be great if someone could help me out with the issue


It sounds like you’ve covered all of the normal troubleshooting steps. Please reach out to and they’ll be happy to help you further!
There is also live chat available during the day at:

1 Like

What phone do you have and are using?

OnePlus 6. The update stops at around 70%

1 Like

Any way you can try to do the update over wifi vs cellular network

Just bought these. Question, does anyone know what are the exact bug fixes. I find my self having to reconnect each earbud to my phone after shutting them off manually and then turning them back on. iPhone 11 user here…

Also the battery tends to drain faster on one earbud then the other. Seems like you have to interchange the earpiece when you connect to the device.

Tested: The earpiece connected to the phone drains more battery then the earpiece connected to the bridged earpiece via Bluetooth.

Is this something normal and anyone experiencing this as well?

Thank you

Just got my liberty air 2 and have the same issue with the firmware update.
My firmware version is 4.15 and the newest version is 4.19, update stop around 70%.
Same with Wifi and cellular network.

1 Like

I’m having the same issue. Although both buds are connected to my Note 10 it refuses to update (from 4.18 to 4.19) Instead I get…Screenshot_20191224-124155_Soundcore|236x500

A message that tells me that both buds need to be connected and then a confusing message about disconnecting then reconnecting them in order to see if they work. They are already connected ,wth. Second time I’ve ran into connection issues with these ear phones.

I am having a similar issue. My firmware update shows the following:

L Version: 04.18 R Version: 04.19
So it seems only one of my Liberty Pro 2s needs the update?

I have the same issue where there update fails around 72%, sometimes even earlier than that. I have also gone through all the troubleshooting steps in this post. Anyone have any updates / fixes?

I have the exact same issue.

Yup, same issue here. (App Version 1.9.3)

I tried to do the firmware update for the Liberty Air 2, followed it by the letter and now got the left earbud version on 4.18 and the right earbud version on 4.19

The firmware update cancels the update process at around 70% (sometimes at around 50 %) with the error message “An error has occured”

Whenever I open the Soundcore App, it doesn’t even let me choose any other setting (like reprogramming the touch controls or set the EQ) since its directly prompting me to the firmware update menu and doesn’t let me switch to any other menu.

This is a big issue which needs to be addressed because we can’t use the Liberty Air 2 to the its potential.

What I have tried so far:

  • clear cache of the App
  • cleared data of the App
  • complete reinstall of the App
  • restarting phone
  • deleted and reconnected the LA2 Bluetooth connection
  • downloaded the Firmware update via cellular network instead of wireless LAN
  • tried with 2 different phones (OnePlus 6T, Sony Xperia Z3 Compact).

Anker devs, please give us a fix for this issue so we can use the earbuds to its full potential!

1 Like

@ChuWie, @DD11, @k3stl3, @aroberts33, @mokap, @dav.gar

We are sorry to hear the issue you are facing. Thank you for trying some troubleshooting already, according to the information you described, the issue you are experiencing is very unusual.

Please don’t hesitate to contact us at by detailing your order number and the problem you come across. We will further help you within 24 hours.


I am having the same exact issue. Any resolution to this problem yet? I have done the same steps as well.

Same issue, L Version: 04.18, R Version: 04.19, update stops around 70%… contacted support, waiting for an answer !

Same issue here. I emailed support a couple of days ago but haven’t heard anything.

Got an answer from support; apparently there’s something wrong inside the earphones and they have to be exchanged. :neutral_face:

I am haveing the same problems

Thanks for the answer @AnkerSupport. I got in touch with the support via email and
got a replacement send out to me, which now work perfectly fine when I do the firmware update.

So everybody who are still facing the same issue; Get in touch with the support via mail and they will send you a replacement after a quick hardware validation.


1 Like

SOOO are the Soundcore Liberty Air 2 headphones defective because I just picked up a pair from Walmart and I’m having the same issue as a lot of you. I’m on version 4.08 and I can’t even attempt to update on a phone running Android 9. I have a tablet running Android 10 I suppose I can try but I just keep getting weird messages about make sure the headphones are pair, unpair and repair blah blah blah. I can clearly see they are pair and uninstalling the app, re-pairing, nothing works.


Try this hard reset of the buds

  • Turn of Bluetooth on your phone
  • Delete the Bluetooth profile for the L2P
  • Put the buds back in the case- leave lid open
  • Hold the button on the back of the case until the LED on the buds turn red
  • close the lid for a few seconds
  • open the case
  • turn on Bluetooth on your device
  • wait for “liberty 2 pro” to show up, and click it
  • wait a few seconds
  • on the screen a pairing request should show up. Confirm it

Now both buds should be connected, and both stereo and mono mode should be working perfectly. You can now try to update then again