Liberty Air 2 - Firmware update failed


I was gifted a pair of Anker Liberty Air 2 wireless earbuds for my birthday in May, and I’ve been struggling to update the firmware since. I love these earbuds so much, but the fact that one side is unable to update from 4.18 to 4.30 really sucks :sob:

I’ve tried holding down the button to reset it, and I’ve tried following various other instructions suggested online, but to my avail, nothing has worked. I even went the extra length to try connect it to various types of mobile devices (android/ios)!

Has anyone encountered such a problem? How did you manage to resolve it?

1 Like

Have you tried a reset first and do that update after that reset?

1 Like

How do I reset the earphones?

1 Like

Please ask google or Youtube, you will find it!

Hey @ijayypee try this,

Put the earbuds into the charging case and make sure they are being charged.
Keep the case open, then press and hold the button on the bottom of the charging case for 10 seconds until the LED indicators on both earbuds flash red 3 times.

Let us know how you get on.