liberty air 2 - cannot turn off by push & hold for 8 seconds

Hello. I have liberty air 2 - latest firmware version.

I push & hold for 8 seconds to turn off but it does not work.
After 2 seconds it triggers the “2 second hold” action.

But even after I disconnect the bluetooth from the phone I still cannot press 8 seconds to turn off.
After 2 seconds it still striggers the 2 second action.

I think this is a bug and can be fixed by firmware.
The 2 second action should be disabled after the device is disconnected!!!

I do not have those but have others. Just to make sure it is not how you are hitting them, I would say try to turn them off one at a time. You should hear the turn off music.

I think those are activated by touch and you may have moved your fingers and deactivated the count…Just a thought.

No sorry.
I touch the flat surface of them. After 2 seconds I hear one “beep”. which means the 2 second hold action is activated.
I keep holding for even 16 seconds (twice as long as 8) but nothing happens.

The 2second action is interfering with the 8 seconds.
Can Anker technician please confirm & log bug request for firmware fix

You should email telling them about the issue. My Spirit Dot 2 does have 2 second touch for Siri/Google Assistant, etc. but the 8 second turn off works flawlessly so something only customer support can help you with this. They can forward that to the correct team and maybe push a new update fixing it if it is indeed an issue or exchange your unit if under warranty

You probably need to check with to get them check it out. If I had that pair, I would checked it out …

Emailed service@soundcore.

FYI other users have reported this issue in this forum so I’m surprised you didn’t know and that this hasn’t been fix yet.



  1. I stated that I do not have the earbuds but do have similar one. So It is not my earbuds of choice at this time and I am not seeking out all issue or resolutions on the Liberty air 2 but did have enough reference with the several other of the brand to try to help out.

  2. I do come to Anker but I do spend more of my time at the soundcore community.

  3. From my search there are a few thread (like 3 or 4 and that was not an extensive search using different criteria) but that does not mean that those issues was not resolved or potentially reported. If it is a firmware issue your issue may be different than others threads.

  4. I am not tech support but a community member like @Shivam_Shah whom was trying to help you out. This is the reason why we decided to send you to the as a community member we have no authority to fix this issue and we do not report other peoples issues.

  5. I believe that some of the firmware has been updated recently. Did you know that the Liberty air 2 has 3 different iterations. One is for the autopause and double tap, one for single tap and no autopause, and I think the last one is one that gives you double tap or single tap.

Thus there are 3 firmware version. 4.xx - I think this is the autopause, 10.xx -this is the no pause and single tap, and the 1.xx that is for the double and single tap.

Since we are community members in order for the techs to know that this is an issue with your earbuds and for other people that may have the same issue, then you will need to report it so that they can see a pattern of users having the same issue. I will say you may want to include your firmware when you do send it as it could help them pinpoint a particular version that may be having an issue.

I will say on the soundcore community, I really do not remember anybody asking this question.


haha didn’t mean to sound angry or anything totally appreciate your help I just meant I was surprised because I assumed this would be a commonly known issue being so basic.

I didn’t know there are different versions of the Liberty iteration.
Why is that?

My friend has these also and their one is what you say “auto pause when taking off the head”
When I first used mine I thought it was a bug or a setting because my one doesn’t do that

I like that option is there anyway to convert or turn that setting on???
my one has double tap & single tap far as I have tested.

Firmware version is 10.12

FYI here is another guy talking about touch 8 seconds to turnoff.
I see he has the same model as me

You are good. Same if you thought I was. We are not for sure. As part of the community and trying to help when we can, it was found out after some many community support. I figure after so many emails to support, they added that to the newer batches.

I think the auto pause can not be turned on as it is a different version of the air 2 or your does not have the sensor on the stem of the earbuds.

Thanks for the firmware n double n single tap info. I mixed those with the 1.xx version but it has been awhile. It is good to know the other guy has the same version. So it may be something they would fix. I think your are the last version they sent out. I will say that on 1.12.21, soundcore is coming out with a new earbud. People are thinking it is air 2 with NC.

The app is already complicated enough. I have the LA2 and to be honest I turned off the buttons as I was accidentally touching them as they kept falling out of my ear and pushing them back in.

If I want to turn them off I can do that by putting the case. Good enough for me!

The ask is going to end up people doing Morse code on their ears transmitting instructions.


1 Like

I would try :

· · · − − − · · ·


.-.. .. -... . .-. - -.-- / .- .. .-. / ..--- / -.-. --- -- .--. .-.. .. -.-. .- - . -.. / . -. --- ..- --. .... / .- .-.. .-. . .- -.. -.--
1 Like

No please!

Otherwise I will use an old German tool.
But may be you know Alan Turing who will help you out! :rofl: