Libert Air earbuds not charging

HI All, I just got a brand new set of Libery Air earbuds but they don’t charge. I removed the protection tape from both earbuds but when I pop them in the case and flip close or open the lid, all 3 leds turn on the case on and after about 1 second they just turn off and no other activity is noticed as if the buds aren’t even there. Removing and inserting the earbuds does nothing. The case though does charge regularly (the 2 leds lit up and the 3rd was flashing slowly until it was fully charged). It appears to me that the earbuds lipo batteries are dead possibly because they have been stocked too long or simply defective cells - just my opinion as I know the charging electronics will not charge cells that are below a certain float voltage for safety reasons (under 2.5V). Anyhow, I don’t know if there is anything else I can do before returning them - any other hints?


If you are looking to see that the earbuds are charging or not, then you should be looking at the LED on earbuds themselves. LED on charging case is just for charge level of case.

This screenshot is straight from the user manual


You may well be correct the buds are dud.


The chance both buds are dud is less likely than one of buds dud. So I’m thinking it may be another reason. Try reseting. This video, the initial steps don’t apply as you not yet paired.

The tap 4 times step.

Thank you all for the heads up and quick responses but unfortunately I did already try all these recommendations in the mean time: I reset shorting out the 2 power pins on the base - the 3 white leds flash to confirm. By reconnecting the USB charging lead they go back to normal (turn on when opening and closing for a couple of seconds instead of flashing repeatedly) and show the base charging state (absorbs about 450mA when last led is still flashing dropping to 150 then stops charging with 3 leds permanently lit). There was never any LED activity on the buds themselves (it’s the first thing I checked) since I first removed the tape and placed them back in the base - the smd led edge opening where the second mic hole is never lit up, neither white nor red, and BOTH are like this. I am sure the base works as I managed to measure +5V from both gold pins of the L and R housings with a bit of acrobatics with 2 pieces of wire. The contacts on the buds are clean so the connection is good. Unfortunately I must conclude that the 2 mini lipo cells are long dead - I have no other explanation.

Thanks again

Have you tried turning them on and pairing to your phone? You can check the battery level within the soundcore app as well to see if they have been charged. If the earbuds are fully charged then even when placed in the case the light will go off after a few seconds like you described. Also if you are using the larger of the bunch ear tips it will take you pushing on the earbuds into the case to make sure they contact the charging pins, the large eartips tend to push the earbuds back and up slightly away from the charging pins thus causing this issue for a lot of people

1 Like

Hi Tank, you see that’s the main issue here: the earbuds are dead, they do not turn on and are so undetectable. I have never seen any activity from the earbuds themselves since I first opened the box and removed the protective film, even after having left them several hours in the case to possibly recharge; they should turn on automatically when removed from the case but nothing happens. The only activity I see is from the 3 LEDs on the case itself indicating it’s charging state when connected to USB power. I have made sure they make contact (you can feel the spring loaded contacts when you press down on the earbuds themselves when in the case) and I have cleaned the gold contacts. I have even checked the presence of the +5V from the case contacts themselves to be sure the case was feeding the buds which it is. I haven’t changed the silicon earbuds from the default small size (I haven’t even worn them tbh).

1 Like

At this point I would return them for a refund or exchange, depending where you got them from. Otherwise reaching out to service@ let them know all you have tried and also provide the serial number and order number or a picture of the receipt as this will help expedite the process

Yes I already requested a replacement form from my C/C catalog (I didn’t buy them directly but through my C/C catalog).


Make sure there is nothing in the charge port, lint, ect. Maybe the case itself is dead?

Got a replacement, all working fine now finally!