LED lights--10 port powered USB docking station

Problem: flash drive(s) going offline/‘not recognized’

I’m experiencing a problem with a few of the 3.0 Sandisk flash drives very periodically not being recognized by the laptop.

The backup software will throw an error to the effect ‘drive letter ‘x’ does not exist’. If I unplug and plug the particular drive the computer recognizes the drive until the next time generally 1 or 2 days later.

Are the blue LED’s that are adjacent to each USB port supposed to be always on when a device is plugged in and is recognized or is the light only on when there’s activity of some of sort or?

Mark

1 Like

Hi @mark61, sorry to hear your flash drives are disconnecting. Is this the product you are referring to?
https://www.anker.com/products/68ANHUB-B10A
There are some FAQs towards the bottom of the page that may help, but if you’re still having difficulties, please feel free to reach out to support@anker.com for further assistance and/or warranty service.

1 Like

Yes, that’s the product.

Oddly, I do have an external HD connected to one of the Anker USB ports and don’t have any problem with it as I do with the low power flash drives (I also don’t have a problem with the two Apple devices connected for sync either). However, I will disconnect the HD and connect directly to the computer.

Can you answer my question about the LED’s?

Mark

1 Like

Hi Mark,
Sorry, but I haven’t used this particular hub so I’m not 100% sure on the LEDs. Please reach out to support@anker.com and the support techs will be able to assist you with that. Thanks!