Led light lights up when plugged but not really charging

Hi! I recently purchased this Anker powerbank II 20,000mAh last August and this month, it suddenly just stopped working good. I plugged it yesterday to charge it and when I woke up today, it was stuck on three out of four led lights. Usually, i will wake up to it already full but it’s already after lunch and yet the powerbank is still with three led lights. I decided to remove it finally and when I clicked the button to check the charge based on led lights, it wont light up. So i tried plugging my phone to the powerbank and it didn’t charge my phone… i tried charging my powerbank again but its now stuck on 1 led light and still not really charging (despite led light blinking when charged)… do you know what seems to be my powerbank’s problem? Thanks!!!

Can you try using a different cable to charge the power bank, also what kind of wall socket are you using?

1 Like

Hi @Dien_Agustin,
May I ask what you are using to charge the power bank? If you’re connecting it to a computer and the computer goes to sleep, it can possibly drain the power bank. For the fastest charge, you’ll want to use a USB wall adapter that can output 2 amps (like an iPad/tablet charger). A standard 1 amp charger (like an iPhone charger) will work too, but it can take up to 24 hours to recharge the power bank.
If trying another charger doesn’t help, feel free to reach out to support@anker.com with your serial number and order number and they’ll be happy to assist further! Thanks!

Hi! I am using an ipad wall socket and the original anker cord included in the box. :frowning: i think there’s already a problem since despite its charging overnight, it should have at least 1-2 bars when i remove it from the wall socket BUT sadly, no, it’s still as if the battery is fully drained.

Im using an ipad wall socket. I already tried different cables :sob:

The Anker cable or ipad socket may be defective, can you try different ones to rule that out?
As @TechnicallyWell mentioned send support an email as they may have to replace the unit

I already tried switching to other cables and wall sockets. Still not charging :frowning: I already contacted them via email and they responded fast. Do you know where to find the order number?

They might replace my unit but I cant find the order number :frowning:

Mmmhhh I guess you’d better contact support@anker.com to ask for their help. The behavior of the power bank is indeed weird to me.

Already did! Thanks!

Hmmm. Whats the problem you encountered with their powerbank?

[quote=“Dien_Agustin, post:7, topic:56649, full:true”]. Do you know where to find the order number?

All depends on where you ordered the powerbank from. If it’s amazon or Ali express you can log into your account and view your purchase history and your order number will be right there.

As far as issues, I have not had any issues with using or charging my 20k powercore

Old post but, I’ve had numerous portables that had the same exact problem happen, I’m not sure why but I suspect it may be some blown fuse or something within the portable. It will light up when you press the button, and then turn off a sec after.

Sorry to hear that. Can you try it again with different cables and different devices? If this still happens, shoot our customer support team (support@anker.com) an email and they will take care of it.

1 Like