Latest EufyCam Software Update Makes App Unusable on iPhone

After the lastest updated software release on the iPhone (4/7/19), my Eufy app opens and loads, but once fully loaded retreats to the background and I cannot use it.

I’m using the latest iOS, 12.2. Is this an issue with anyone else? Is there somewhere I can get support on the weekend? I want to turn the cameras I only use at night off. I’m getting way too many notifications.

Thanks for any insight.

I now realize that the above post is under the entire line of Eufy products, so I guess I should clarify that this is for the Eufy Cam security system.

too bad…not a good decision to go with most latest version of iOS and neglect the previous versions

I’m having the same issue. Any word on a fix?

Anker / Eufy should update the iOS app to fix the issue, or put a disclaimer to Eufycam users not to update the iOS software.

Apple is right on it’s part to update its OS.

Unless the users have a spare device with previous version of iOS < 12.2, there seems to be no other way but to wait for Anker to fix the app.

Uninstall the app and reinstall it from the App Store. Worked for me.


May be this removes the old cache from the app and resets the connection to the EufyCam

thanks for the suggestions

Thanks for the suggestion @Springfield

This only worked for me temporarily. After awhile it will crash again

Also the app started crashing for me after the latest app update and NOT the 12.2 update as others mentioned.

Paging @AnkerOfficial