Keyboard A7721

I was pairing the keyboard with my laptop when a PIN came up on the screen. I clicked on the link, the PIN disappeared, and I got a message to enter the PIN, which I no longer could access and hadn’t written down (DUH!). Now every time I try to pair the device it asks for the same pin. I can’t delete the device and start again as it hasn’t actually paired yet. Any ideas?

Have you tried pressing the BT button the keyboard for 5-10 seconds to stop pairing mode before trying to complete a fresh pairing?

1 Like

Try what @ndalby suggested. I had this happen on my Windows 10 pc a while back. I had to hold the BT button to get the process to start over.

None of the above worked. Saw something that said it might be my Bluetooth driver as newer versions shouldn’t be asking for pins but that didn’t work either. Really at wits end with this whole process.

@iamfredp have you tried entering 0000 as the pin? You could also try reaching out to who might be able to assist further with the issues you are having.