Issue with ZOLO liberty+ Charging Case

I got these headphones about 2 weeks back through the Kickstarter (was gifted these by the girlfriend). Opened them and charged them prior to the first use. They worked fine for the first week. Week 2, the case is failing to charge when plugged in. I’ve tried several different cables and different power sources. The power sources were also used to charge a backup battery and phone, so they work. I’ve narrowed it down to the case. Its down to 2 lights and when plugged in is no longer blinking like it should be. Is there a way to re-set the case?

I’ve sent an email to customer support and still am awaiting a message back.

Is anyone else having this same issue?

Also my headphones are only charging to 90% each time. I’ve Unpaired and re-paired them several times and still having the same issue.



Your issues has been delivered to our customer support team, they will contact you as soon as possible.:innocent: Please check your email box today.

1 Like


I have the same issue on the charging case. May i know the solution?

1 Like

I seemingly have the same issue, there’s only 2 lights at most.

1 Like

Hi @Waikit_Choi, and @Kahocheong,

I’m sorry to hear your issues. To verify the issue further, could you please contact "" to
communicate your problem?

Please be assured that we offer 18 months warranty(replace or refund) and lifetime technical support. We will try the best to help you.

I too have the 2 light only issue with the battery case. What’s the solution?

1 Like

To better solve your issue, would you mind to contact "" to communicate your problem?