Iphone doesn´t recognize power core always at first attempts

Hello dear community,
I recently bought an Anker PowerCore 20100 including original Anker lightning Cable and extra wall charger.
So far so good. The powerbank is loading very good, then I want to charge my iphone 6 and 7 with it.
It seems that the phone doesn’t recognize the battery always at first attempts. I often have to plug the cable from one usb port of the powerbank to the other and back, and back and forth….
When the phone recognizes the powerbank, the loading is very good, but its really annoying.
Can anyone tell me if that’s a known thing or maybe its just a bad item I got ?
Thx so far.

1 Like

Hi @chrissi0179 , I’ve seen this happen a few times on an iPhone 6s when it is on the lock screen (on a few different PowerCore models), normally pressing the battery indicator button on the PowerCore kicks it to life and it starts charging.

Was your iPhone on the lock screen when the issue occurred or on the home screen?

On the whole it should detect when connected and start charging, if you can replicate the issue on either another device or with a different cable I would reach out to support@anker.com with your device serial, issue and troubleshooting steps taken for additional support.

1 Like

I found its always best to press the Power button on the powercore first before plugging the device in so it gets recognized first try

It is a good habit to get into and I do it often before connecting anyways, just to make sure there is enough juice left in the PowerCore in case it’s been used by another family member on the sly :grin:

1 Like

I also had this behavior with some specific models of external batteries. I think it’s actually a feature, rather than a bug.
Some PowerCore batteries need us to press the button to start charging.

FYI, it’s not the case with the new PowerCore II batteries. I received one last week, and there is no need to press the button beforehand.

I also have the new powercore 2 bur you still do need to press the button beforehand on the older iPhone as it will do the same as the op mentioned and not charge. I know this because my son has an iPhone 4 and it’s the same way

Hey ndalby and all others,
thx so much for your quick reply.

Sometimes it was at locked / in lock screen mode for sure (the phone).
But other times it wasn’t, was completely opened / unlocked properly because I wanted to check for the icon if its loading or not. And still the same result.

I figured it could be fixed by change the charger USB cable from one port to another and back and forth at the power bank, sometimes it was also possible by clicking the button at the power bank, but that just very few times.

I use only Anker products now in this process (except the iphones :wink: )

Its definitely able to replicate.

(Changed profile meanwhile, sorry if any links may broken or other trouble caused by that…)


Right now i have the case, that the battery wont charge no matter how often i change the port or whatever.
Now i turned the phone off to see if it can be loaded while turned off, now the powercores leds are lighting but the phone doesnt show that.

i thought maybe ist a problem with my phone but i tried it also with my iPhone 7 and phones of colleagues.
Really no clue. :frowning:

UPDATE 2 (maybe solved):

I did some crosstests with the cable and a pc. if i use the original apple lightning cable the charging starts immediately . After that i tried to use the Anker cable as the USB connection to my pc for the iPhone.

Then i was curious and tried to move it around a bit. And I think when I lifted the USB connector a bit on the cable upwards, then the connection was established. So it may be the cable is damaged ? Can it be controlled anymore or should I just talk to support now ? If yes, should I do it here at the site or over amazon where I got it over ?

Thanks for all further comments in advance.

Send them an email....support@anker.com
and they will further assist you as it seems to be the cord is the issue

Most faults are often cable related. I take it the PowerCore behaviour does not occur with your original Apple cable? As mentioned previously it would be best to reach out to support@anker.com with your troubleshooting steps taken so the cable can be replaced…

MMMh ok so I guess the difference is OS-based. I have an Android phone.

Hey all,

i contacted the support now and will see how it works out.
Thank you all so much for your help and experiences so far.

I definitely stay satisfied with Anker products as well as with the community. :slight_smile:

I found that If you insert the usb cable in the power bank slowly it won’t recognize that there is a usb connected.