IOS12 - This Accessory May Not Be Supported

I bought a PowerLine+ Lightning cable last Feb 2018. Just this August, I started experiencing connectivity issues with my anker cable. I always encountered this pop up “This Accessory May Not Be Supported” every time I charge my iPhone. Went to where I purchased my cable and I was informed that a lot of people have also experienced same issue.

an Anker Employee told me that issue might probably due to the iOs update of Apple. Mine is on ios12 now but issue started when I was still on iOs11. They changed my cable to brand new, thanks to the 18-Month Warranty, but unfortunately I am still encountering the same issue on my phone.

I thought that the issue might probably due to my charging pin but I also tried charging my phone using my old apple lighting cable and no issue encountered.

Hope you could provide some feedback/help before I send my new cable again to customer support.

I also tried rebooting m phone by pressing POWER+HOME but problem still not solved.


Hi @John_Rhenan_Dunlao,
I haven’t encountered any issues using Anker cables with iOS 12, but one thing you can check is the charging port of your phone. You can use a wooden toothpick to get out any debris or pocket lint that may have accumulated there. If the Lightning cable can’t make a full connection, it can cause the “accessory not supported” message to pop up.


I really don’t think that the issues are depending of the OS-version.
There might be another reason.
Try to follow the suggestions of TechnicallyWell. May be that helps.

I agree with @TechnicallyWell and @fhassm, definitely check your port. I’m running on iOS 12 and haven’t had any issues with any of my Anker cables. Hope it’s just an issue with dust in your charging port.

This sometimes happens if the MFI chip is damaged or bent in any way, I would do some more research, and get it warrentyed if you can’t find any solution.

Both hardware and software can cause this problem.
Hardware problem: The accessory has not passed MFi certification.
Software issue: iOS version is low.
Solution for “This Accessory May Not Be Supported”: Clean the charging port and wirelessly update iOS to the latest version.