Imposible Update firmware Nebula Capsule

Hi, I need your help, I don’t know why I cannot update the firmware of my Nebula Capsule, it’s NBU_M1_V1.0.46 and Android version 7.1.2, but when I try to do it, this message appears ‘Latest version failed’ and this result is over and over again when I push ‘try again’
Anybody knows which’s the solution?

P.S. Sorry for mistakes, English isn’t my native language

Yeah I just bought the capsule and can’t get any apps to install and firmware hangs at 51%. Says to update to NBUI_M1_V1.0.83. Try Again over and over. Not my network as everything else is fine. Is there a location I can get the firmware from directly?

I don’t have a Nebula Capsule but maybe try to connect to a 2.4Ghz wifi channel. You might be using WiFi 5Ghz and I know some devices only work in that specific 2.4 range.

Yeah I’m running off the 2.4 Ghz, I did try 5Ghz when it wasn’t working but had the same results. I also did a factory reset and cleared the cache. I’m based in Australia so not sure if that makes a difference.

1 Like

I have the same problem, udapte stuck to 14%… i cant update firmware… any solution for this ?
We cant update manually ?

ok problem [Solved)
When I changed the system language from English the problem solved.
Let’s go guys, change language by default

1 Like