I bought the powercore20100, went from extremely impressed to bitterly concerned

Opened it up charged it to full, first week i couldn’t believe my eyes, gaining oodles of charge whilst playing anything on my samsung 6 edge.

Now im losing charge as i charge :stuck_out_tongue:

Whats happened? I’m still using the cable it came with and i charge it from the wall with a 5v 2 amp charger

Model: A1271
Input: 5v 2a Output: 5v 4.8a

Thanks all

What wall charger charger are you using? If its a standard OEM style charger it isn’t powerful enough to charge.

I have one of these power banks it won’t even charge with my standard OEM charger. If it were to charge it it would take 20 plus hrs to charge.

When i first got mine, i used an Anker Elite Dual Port 24 watt charger ( i think that’s the name. I don’t have that charger anymore). It charges the power bank fast.

I believe you need a charger that is 24 watts or more for quick charge.

Anker Elite USB Charger, Dual Port 24W Wall Charger, PowerPort 2 with PowerIQ and Foldable Plug, for iPhone Xs/XS Max/XR/X/8/7/6/Plus, iPad Pro/Air 2/Mini 3/Mini 4, Samsung S4/S5, and More https://www.amazon.com/dp/B071YMZ4LD/


Are you sure it’s charging? The LEDs are on? Push the button if not.

1 Like

Hey, how does the charger i use to charge the powerbank up affect the rate at which the powerbank charges my phone?

Im using a cheap but powerful one off amazon, matches the input values on the powerbank

Im guessing this must be the problem but why has it taken a week for it to suddenly swap to slow charge mode?

Thanks dude

100% on, functioning like it always has but now at a very slow rate :frowning:

Wait, ive misled everyone, the powerbank charges phone it just slow charges my phone now

O ok that makes more sense. The amazon fast chargers should be fine. Curious what’s the wattage?

What phone are you using? Have you tried other cables?

From my undersranding, issues like this are generally a bad cable, bad connection on the phone, debris in the ports or inside the cable port. Sometimes its a harware failure.

My suggestion would be check your cables, phone, power bank to see if there’s anything blocking it.

Also restart your phone, I’ve lost fast charge once and needed to restart it. Fast charge came back.

If those steps dont work, I’d email @AnkerSupport at support@anker.com and tell them about the slow charge. Make sure to tell them when/where you putchased it, serial number and what steps you have tried. These are questions they may ask for up front and it will speed up the support process.


Everything is pretty new, ill try all steps and report back thanks friend

Its just acting polar opposite to how it was, ive made sure everythings clean and secure.

Cant see any anything wrong at all, absolutely bamboozled.

Only things i can find are the capacity input and output idk what the wattage is.

The feeling in my stomach tells me something brand new that worked for a week solidly shouldnt be acting like this without any significant change.

Id rather sort it than resend but cant find any solution online. Ill ask support.

Maybe you are using your phone a bit differently. Maybe you are playing more power-hunfey games or perhaps watching a movie. Oraybe increased the brightness on your phone. Those are the only things I can think off since you have the same setup as last week’s