How to setup RTSP on eufyCam to stream video to your compatible NAS

By enabling RTSP (Real Time Streaming Protocol) on a specific eufyCam, the system will save all its recorded videos to your compatible NAS (Network-attached Storage).

Note:

  1. The RTSP function on eufyCam only works with NAS that supports RTSP protocol. In this FAQ, we will be using Synology NAS as example.
  2. This function is now available on Android App v1.1.1 and iOS App v1.1.1.
  3. When user is watching live or the camera detects event and starts recording, the video will stream and save to the NAS.
  4. When the camera is in standby status, no video streams to the NAS.

Step 1: Install Surveillance Station on the NAS

On your NAS, log into the NAS management page.
Go to Package Center, search “surveillance station” and install.
Once installed, the Surveillance Station can be found in the Main Menu.
Note: the software and package in different NAS may vary.

Step 2: Enable RTSP on eufyCam

Go to Eufy Security App - a specific camera that you want to stream to - Camera Settings - NAS(RTSP Stream).
Enable NAS RTSP Stream.
Write down the RTSP stream link for later use.

Step 3: Add eufyCam to the NAS

Open the Surveillance Station.
Find and click IP Camera on the left side.
On the new window, go to Add → Add Camera.

Select Quick Setup.

Name: give a name to this camera
Brand: choose User Define
Type: keep Streaming - RTSP
Path: input RTSP link indicated on the App.

Updated on 2019-01-11: Trigger the camera (you may walk or wave hand in front of the camera), so that it wakes up and push stream to NAS.

Then it will pass the Test Connection. If it fails, please disable and re-enable the “RTSP Stream” button on eufy Security App > Camera Settings > NAS (RTSP).

The captured videos can be found in Surveillance Station - Recording.

7 Likes

Doesn’t work for me. Camera Test failed every time. Camera FW = 1.7.1; HB FW = 1.0.6.7; App = 1.1_173 (iOS).
554 port is open.

No work with Synology NAS

As a test I tried to open the RTSP stream inside VLC Player and it kept causing the app to crash each time.

Same, tried many times with Synology DSM 6.2.1-23824 Update 4 and Camera Test fails each time. Attempted to add with all optional parameters supplied as well (username, password, etc)

Synology NAS DSM 6.2.1-23824 Udate 4, Surveillance Station ver 8.2, followed this setup and does not work. Test failed. On rtsp field also tried IP:port/live1, still failed.
Base Station, camera version, IOS version all up to date.

Pleast try live-streaming the camera before submitting the setting or running a connection test. Afterward, the camera will start streaming and pass the test.

I’ve already tried live streaming of my camera then hit the test button.

The same here. All firmware and apps running on the latest version.

same here.

Synology NAS DS214+

All firmware and apps running on the latest versions as well.

1 Like

can’t get RTSP working here as well, DS712+ with latest DSM 6.2.1-23824 Update 4
… also tried multiple times to switch between Liveview and Surveillance Test Mode, no success yet.

so I got it working on my SurveillanceStation…only via motion sensor triggering the camera…
that’s kind of “not good”.
The RTSP Stream is only available, if the camera is triggered…this results in a huge amount of error message on the SurveillanceStation, due to connection loss and reconnects.

The stream needs to be changed to be always available.

I already wrote on kickstarter, no answer yet.

The system, as is, is not as promised and if this issue is not solved soon, I will refund my 3 cams…it’s not, what I bought…

1 Like

Same issue here: attempting to stream to VLC results in nothing. Latest iOS app, latest firmware on the based station and both cameras.

I want to confirm: is a NAS required for RTSP to work on these cameras? Or is a NAS only necessary if I want to save clips?

I followed your instructions and I did the connection test (NAS Synology) during the live streaming of the EufyCam. The test always fails anyway. You have to fix the bug. Thanks

don’t live stream, trigger the recording at the camera…send your dog infront of it, run through after you clicked, what ever.
Streaming through app does not work…triggering does.

@Springfield @pino @Pilkie @hutthuttndabutt @Steve_Liu @Danysahne @wus @JGR @Flauschi @bachya1208 I’m sorry to hear that it didn’t work properly. We have updated the ways of setting up RTSP on eufyCam to stream video. Please follow the step above and try again.

1 Like

Thanks @AnkerOfficial, it’s a step forward but it’s very annoying to have to restart every time. I hope that you will be able to make the operation more performing with a next update.