Homebase 2 will not reconnect after reset

I recieved a few more pieces of my Eufy security system and moved the home base 2 to its final location. After unplugging it to move it it would never connect to wifi. After troubleshooting I reset it. It will not connect to be resetup again.
I have reset it numerous times with different results.
I have had the flashing blue light, solid blue light, red light, and have reset them in while in those states. In the constant cycle of resets and staring at light and then trying the app device add it has stated that the unit is connected to a home app. Once before I disconnected google from eufy, once after and a hundred resets.
What am I missing here? If I can add anything that could help me getting some useful support just ask.
Thanks in advance,
Indecisive New Eufy User


Waited over night. The Homebase connected after a single reset this afternoon.

Glad it was able to reconnect

Was waiting the magic answer? I’m stuck in the same endless loop of “must reset.”

I have reset my homebase2 over 20 times over the course of an hour, and it’s just not working

1 Like

I guess waiting did it.
I turned it on after work. It stuck at the red light. I reset it. Then rebooted. It did not scan the first or second time, but the third time grabbed finally and the misery was finally over. Easy setup. All components worked correctly. Wifi worked again as well.

Happy for you. I’m still stuck in the endless “Homebase must reset” loop.

I contacted eufy support and they kindly asked me to wait one week for a firmware update.

This system hasn’t worked for half the time I’ve owned it. It’s a shame, it was great when it did.

Try plugging it in. Hit reset. Unplug. Reset again. Then unplug again. Then when it turns blue, blinking or solid, try to connect with the app. Try to add it 3 or 4 times in a row. That’s the procedure I performed.

Thanks for that. I’m fairly certain that I’ve attempted every last permutation of:

Power cycle
Attempt to sync

But I’ll give that a whirl. I escalated my case with eufy, and a senior CSR responded “we should have a firmware update in 1-3 days if everything goes well.” Their track record of delivering updates in a timely (or advertised) manner isn’t good. Also, without being able to connect to it, I’m unsure how on earth I’m supposed to do the firmware update. Sheer willpower?

I felt the same way when I was fighting with the thing. I was very frustrated and inpatient, so the next I walked up to and it went down as described. The first couple of tries and it failed, my heart just sunk. Then I tried it again and it took immediately. Did you notice the screen change/ flicker the push red button screen real quick before it failed at any point in tour attempts?
How would the firmware work if it doesn’t connect? With a USB?

I haven’t noticed much weirdness in the app, no flickering to speak of. On multiple occasions the app would reject the QR claiming “incorrect code” and it would reject manual entry of the 8 digit code just the same. After a reset it would resume scanning the code correctly, but then complain that the homebase needs reset. The broken English somehow makes it more infuriating lol.

I have noticed some tomfoolery with the LED on the homebase. I know my network is correct. My Comcast modem is in bridge mode and IPs are issued via DHCP by my master mesh router.

Sometimes the LED blinks red infinitely or remains solid red until I reset, even though the router confirms the IP assignment. Most of the time it reaches sold blue though.

I’m just getting home and preparing to give it another go.

Yeah. Dang. Tried all that and then some. Tempted to huck this piece of trash out the window, but I’m going to return it.

Eufy support is horrible. Random people on this forum are more helpful (not a burn on you, you’re great!) than eufy who just feed me canned responses and promises of future firmware updates which I don’t know how ill be able to apply…

For anybody else going through this, here was my solution which worked perfectly!

Initiate a return
Package and ship back to eufy
Buy another camera system

Couldn’t be happier!

Thanks for your help though.


Going to try the same. Total joke of a system.

Been stuck on Reset loop since I had it middle of last week. I was told on Friday just fine an update would be out in 48 hours. If nothing by tonight it’s going back and I’m off to Anker or Netatmo.

I use HomeKit and HomeBridge, so I bought the Logitech circle view cameras and a ring doorbell. Everything works perfectly, picture quality is better, FOV is better… cameras are wall powered too.

1 Like

Thanks for the update. Looks good.
Sounds like a plan. I use Homebridge as well.

I just bought a homebase 2, three cam 2 pro’s and the wired 2k doorbell. I thought that getting all the same items from the same company would ensure there’s no issues. I’m having the same issues as many of you. My homebase mostly flashes blue, but will never connect. I thought it was my router, but after resetting that changing my wifi, etc. I’m sure it’s the homebase. I’ve reset that 3 times, held down the sync button until it turns red a few times, and used both the scanning qr code and manually entering the numbers in… nothing seems to let me connect.
I have no idea how to check the firmware on the homebase, or how to update it, if that fixes the problem. Honestly, should I send this all back?

Yours sounds DOA. Did you try Eufy support? You can do a chat on your phone during business hours.

Mine has been working fine since the last problem. So I have been able to use it and learn the limitations of wireless cameras. There is no comparison to a wired system with a dvr.

I’ll be calling them as soon as I can today. I left it plugged in all night and this morning it was still blinking. I reset the homebase again as well as my router and still the same results. I’ll post in here what the results are from the phone call. Thanks!

So, it’s all fixed! I noticed there was an updated app on the app store today, so I downloaded that and tried the process one more time. Somehow the updated app worked! It’s weird that the app that was on the app store YESTERDAY didn’t work, but today’s does… anyway i synced one camera as a test and it worked wonderfully. This weekend I plan on tackling installing the 3 cams and the doorbell. Wish me luck!