Homebase 2 Solid RED circle after switching from Ethernet to Wifi.

Brand new Eufy Wifi Doorbell unit just arrived from BestBuy today. Been having issues setting it up. So I have already spoken to Eufy support and they advised me to do a Homebase 2 replacement. But I wanted to know if I was the only one seeing this issue or should I be concerned with this whole product line.

Setup seems like a breeze right until the part where it asks you to remove the Ethernet cable so it can switch over to Wifi. I get the notification that it is connected successfully to wifi once I remove the cable, blue ring then turns to a red blinking red ring, and then solid red ring and never changes after that. Everything at that point goes OFFLINE on the app.

  • Unit works fine on Ethernet connection.
  • Made sure to update to the latest firmware.
  • I have already reset the entire unit, removed it and reinstalled it from app twice.
  • Power cycled both Router/Phone/Homebase‚Ķ multiple times.
  • Internet is fine no drop connections.
  • Confirmed Wifi is working and password is correct, no blocked ports on 2.4 GHz

Am I missing something? I know Eufy said they can replace it but I just want to make sure it is not something I overlooked. I mean a defective unit straight out of the box is not very inspiring. I have more Eufy cameras I ordered that has not arrived yet and now I am 2nd guessing my choice. Hopefully, someone might have had this issue before and fixed it or maybe just my bad luck and got a defective unit out the box.

Make sure your on 2.4Ghz wifi network, also make sure your router has enabled DHCP. Check your firewalls if your router has one built in and enable it to allow connection to the homebase

Thank you for the help.
Been working at it with no luck still.

*Wifi is 2.4Ghz
*DHCP enabled
*Tried different channels
*I disabled the Firewall completely on the router.
*Firmware is updated on router
*Rebooted both Router and Homebase a few times

Will try a complete homebase reset again tomorrow. Wish me luck!

Update, still waiting for Supports help with the matter. Seems like homebase is not switching over to wifi once unplugged.