Help with my PowerCore+ 20100!


Yesterday after work, I tried plugging my phone into the device to charge, but noticed that no charge was being given. Upon looking at the charger, the lights were blinking as if the battery was plugged into a wall and being charged (to try and give a visual, the lights were lighting up sequentially in the circle, then the last light would blink, indicating that it was almost charged). I didn’t know what to do, so I plugged the battery into the wall to see if anything would change. Eventually, the lights on the battery stopped blinking, so I assumed it was fully charged.

Now that I try to use the battery today, the lights do not light up at all, whether I press the button, plug it into a phone, or even to the wall. I’ve tried using different cables, different ports, continuously pressing the button on the battery, and the lights do not show, nor does the battery provide any power to my phone.

Is there a way to troubleshoot this device, or is it broken? Thanks for the help!

Hi @Patrick_Nguyen1, sometimes the safety circuit can kick-in which may make the power bank appear “dead”. Please try leaving it alone for a few hours and it should eventually reset. If it does start working again, you’ll want to press the LED Power Wheel before connecting your device to activate USB-C output (otherwise, the power bank may draw power in from your device).
If it’s still not working, feel free to reach out to for further assistance.

The battery was left alone all night and I did not try to use it until earlier this morning. By my estimates, the battery had just about 8-10 hours of being left alone. Should I still be waiting it out?

That should have been enough time, but keep checking it periodically to see if it comes back on. In the meantime, please reach out to and the technical support staff will be happy to assist you further.