Help - it's like I've turned on numlock on my A7721 keyboard - and I can't turn it off?!

Hello - I’m stuck. When I press ‘e’ my keyboard types ‘e4’. when I type i it’s i9, and other weird things are happening with the top row of my Qwerty keyboard.
I can’t seem how to turn it off or switch it back.
I’ve tried unpairing and turning on and off, and even resetting keyboard type, but the problem is still there.
Help?! Does anyone have any ideas?

Hi @beth_h and welcome to the community! What device / OS are you using the keyboard on?

Hello! Thanks for the quick reply. I’m using it with my macbook (10.14.6) Is that the info you need?

Thanks. Have you checked you haven’t enabled numlock under MacOS via a function key shortcut and that your keyboard language is correct in system preferences?

Thanks - my normal keyboard on my macbook is working fine. And I’ve reset the language of the bluetooth keyboard and nothing is working. Argh.

It could possibly be a macOS compatibility issue with Mojave, as El Capitan also had some issues with this model of keyboard. Did you get the identification wizard after a fresh pairing of the keyboard (press key on the left and right of the shift keys etc)?

Tried mine under Catalina a few moment ago and functions appear to be normal on either keyboard :thinking:

Have you reach out to yet with the issue?

Sticky key!

Try gently removing the key top, and give the key part… Usually a small button with a spring.

So although it looks it, it may not be releasing, so give it a clean… It happens!