HDMI on Anker extender failing

I have a Anker PowerExpand – the 7 port one. I just got a second one because the usb c connector was damaged in a fight with my Roomba.

I installed my new Anker PowerExtend to replace the damaged one. Before I could use HDMI cable to use my larger display screen from my laptop. The laptop screen is a little small for me to see properly.

This no longer works.

The screen/monitor and cable still work. I checked it by plugging it into Roku via HDMI as well as my old computer which has an HDMI output (but other problems). The screen and cable work.

But the Anker PowerExpand is no longer putting out an HDMI signal. Usb ports work to plug in my extra key board or a mouse.

What could be wrong? I’ve also moved the extender to usb c other than the one involved in the ‘fight’.

No computer shops seem to be open now…

Try fully powering off the laptop.

Make sure it is actually off, not suspended, not just a reboot. Don’t have the dongle plugged in.

Then power on.

Once it’s up then plug in dongle.

Is it Windows? If so go to settings, system, devices, and scroll down to anything with a question mark next to it, then disable then enable.

That then may fix it. If windows sees a dud device it sometimes disables it despite you replacing device, so have to force it check again via either reboot or disable/enable. I had a PC once did that every now and then on a Wifi dongle.

What is your laptop make and model?
Is it Windows or Mac?
Optional step - do you have a Samsung Galaxy S8 /9/10? Try the mirroring or DeX mode to ensure the Hub is working well.

I don’t have a Samsung phone. I have Samsung laptop (described above). It runs windows-10.

Before the accident that destroyed the usb c input to computer on the hub, HDMI did work. I didn’t do anything to the computer, but got a new extender hub to replace the broken one and now HDMI doesn’t work on that though the usb ports do.

I tried moving it to other usb c inputs on computer but that didn’t help.

Possibly I could try hub on my daughters old Mac though not sure it’s set up to do HDMI anyway, so that might not prove anything.

Did you try the disable enable post a power off on?

The earlier device which broke can trigger windows to disable the device, so when you replace with new it’s still disabled.

Windows sees the hub and sees each device at end of the hub so simply swapping hubs doesn’t enable a disabled device far side of the hub.

Some devices are direct plug and play and others have to be configured, and yes even similar devices whether brand new or not may act differently and has to be told what to do.

With that said, plug the adapter in and hook it up to the TV or whatever you want to use as a secondary screen. Then follow these steps:

  1. right click anywhere on your desktop and click on Display settings
  2. Make sure its showing the correct number of displays, if it is not then it needs to be configured
  3. Make sure everything is plugged in and powered on, then click on detect display button
  4. Scroll down to Multiple displays, if necessary, click the drop-down menu, and then select a display option.

To set up a wireless monitor, click Connect to a wireless display.

If you cannot change the display options, go to the section to Configure the display with the graphics driver .

  1. Adjust screen resolution and orientation as needed

  2. Extend desktop only and match the monitors to how you have them set up. Click on keep changes and it should work now

Hi, I’ve got the same issue with an Anker Hub. HDMI is not sending any video inputs as shown on my monitor as well and I didn’t have any issue with this port prior to this. USB-C is working just fine, only the HDMI is not doing anything. I tried every step, that you suggested, but nothing seemed to help.