Flare+ Won't Connect to Soundcore app

I paired my new Flare+ with my iPhone, but when I use the Soundcore app to connect it won’t work. It keeps saying retry. I’ve unpaired the device, but it still isn’t working. Any suggestions?

Hi @mark_schwartz and welcome to the community! Have you tried fully closing and reopening the app after the fresh pairing?

Also iOS or Android?

It’s an iPhone 7+

I have closed the app, unpaired the Flare+ from my phone, removed the app and downloaded it again. Just got off the phone with Anker support and they want me to do an exchange. I feel like there has got to be a way to make this work.

Give it a try, nothing to lose though…

  1. Have you restarted the phone? please try to Restart your phone and see if Soundcore App detects the Flare+, else do below
  2. Delete the Soundcore App completely from your phone.
  3. Remove Soundcore Flare+ from your device’s Bluetooth history and ensure it’s less than 3 feet away. Then try pairing again.
  4. Install the app again.
  5. Try to see if the Soundcore App is now finds /detects the Flare+

Do let us know!

I restarted my phone, and deleted the app. When I first select connect it takes me to a screen stating to select your sound core device in bluetooth settings. I then select the Flare+ in my Bluetooth settings, and try to connect again, with no luck. :anguished:

1 Like

Do you by any chance use iOS BETA / Developer version? Try to update it if you do use, there was a new version of 13.3.1 available last week.

If not, contact Service@soundcore.com to check for firmware update for Flare+

Also have you reset the Flare+? Try to press the Volume Up and Down button together for 3~5 seconds, should see the blue LED flash, try to pair with iPhone.

I do have a beta IOS, ver 13.3.1. I held the plus and minus, but there was no blue light flashing.

Whe you tried the reset, was the Flare+ powered ON? Power it on and try it again please.

On a separate note - If it is a beta, then it’s a iOS issue, I can confirm it.

I updated my iOS yesterday to latest beta, and now I am not able to connect to my Soundcore Liberty 2 Pro on Soundcore App. I am planning to update iOS next week when the update is available and test it again.

Please proceed to contact Soundcore support for the issue and let us know if you get a working solution.

Thanks for your help. The Flare was on when I pressed the buttons. Where is the blue LED located? I don’t mind waiting for the next IOS update to try again. The Flare+ works as I can play music from my iPhone, I just can’t use the Soundcore app to apply updates.

Regardless you should be able to pair and use flare +

It is not blue but white light on the buttons.

A new update to IOS came out today and I updated. Still not working. Anker won’t support my issue because I bought my Flare+ on Ebay (brand new). True the speaker works, but I can’t take advantage of the updates. I downloaded the firmware tool on my Mac today and received the following msg, " “AnkerProduct” can’t be opened because Apple cannot check it for malicious software."" I’m feeling a little disenchanted.

After looking through the Soundcore reviews I found the problem. After selecting your device in Soundcore (Flare) you must swipe to see further devices, which in my case is Flare+. The GUI gives no indication that you need to swipe to see additional devices. Based on the Soundcore reviews several others have had the same issue. I would suggest a GUI update so it’s more intuitive. Either way, I have now been able to connect, update the firmware, and customize the music settings. Thanks for your help!


Thanks for posting the update! Glad to hear it’s working for you… :+1:

Sometimes the issue is so simple, and we look at complex solutions :wink: and I am guilty of doing it now

OMG seems like the Ux designer had a bad day when coming up with a solution that gives no hint on more options to the user, thx for posting this I was lost on the very same page,

Ref. the Soundcore Flare not connecting to app…where exactly do I have to ‘swipe’ please?



When you select the Flare Series option under speakers in the app, you need to swipe right to left to select the correct model variation before pressing connect.


I did all that thats written above, I swipe in the app select the correct model Flare, that is says to go to bleutooth sertings and select device, At bluetooth settings I select the paired Anker Flare and then I get the message app needed to use device. This is with all our android 10 device. When I try an old iPhone 4 or Android 7 no problems I don’t need the app, paired and ready… We use Samsung, Xiaomi, Asus and all have the same issue. Please help thank you!

Screenshots please, not understanding.

Hi, screenshots attached, as I wrote it tells you appis needed for this device. Speakers are paired but do not work, when you select them under bluetooth settings you get “needs app to work…” I gotothe app, swipe select the correct device, it tells you to go to bluetooth and there again “needs app to work…” If you select settings you see the speakers but can’t do anything. This is on all android 10 phones as I wrote Samsung Galaxy several models, Xiaomi Rednote Pro 8 and 9 and Motorola. It works fine under iPhone 4, old Android 7 and 8 phones. I tried it with friends phones all Android 10 sane issue. I contacted support and they claim they never heard of the issue couldn’t help since I didn’t buy it of them directly. I ordered another set from Amazon exact same issue.