Fail to find homebase

Why doesn’t it work? It’s connected to the internet, same router, tried restarting, uninstalling, clearing cache, everything. Still fails? Great. QR code does the same thing.

Hi @Jitsukablue I would suggest you send a email with your issue and devices being used for a quicker response.

As the EufyCam’s get a bigger foot hold in the community FAQ’s and the such will most likely cover such issues that buyers are having…

Thanks @ndalby… I already did yesterday, and got zero response. Not even a “we received your email” type response.

Try restarting the app and/or phone. It worked for me when I got my system about a week ago.

Eufy emailed a few days ago saying they had fixed a server problem which they thought was causing this issue, but maybe not?

Have you tried the live chat service? They currently have some operators online now…

Go to and click on the symbol in the bottom right corner

You can either use the automated response system or chat with an operator…

I added the serial number manually, I didn’t know that was an option. All working now!

Contact they will offer you a replacement. Like if helped:)


Really? Are you saying it’s faulty and needs replacing?