eufyCam - How to fix the clock time?

For months now, my eufyCam setup has been about 38-45 minutes out for clock time. There are many threads about this and I think I’ve tried all the suggestions made:

  • Restarted Home Base
  • Logged out from the App and logged back in
  • Removed and readded the cameras
  • Removed and readded the Home Base
  • Changed the timezone, left it for 3 hours and then changed back to my correct timezone
  • Formatted the SD card
  • Disconnected the Home Base power and let the backup battery drain

After all that, now the clock is 4 hours and 23 minutes slow!

How does Home Base set its time? Is there a trick or hack to force it to resync, or manually set time? My network allows all protocols outbound. However, packet capturing suggests that the Home Base never makes any NTP requests.

My versions are:

  • App: 1.6.7_491(EU) on Android 10 (Jan 2020)
  • Home Base:
  • eufyCam (original): 1.9.3

Are there any other suggestions? Please Help!

Hey @Pug50 , thanks for reaching out!

In this case, could you please set the timezone at anyone, such as (GMT+08:00) Hong Kong, then change it to your right timezone to see how it works? You are able to set the timezone via my device>homebase>timezone.

If the issue keeps coming back again, please let us know we will further look into this case for you.

Hi. Thanks for replying.

I’ve tried that previously, but I just retried that suggestion since my Homebase recently updated to

My problem remains. :frowning: