Eufycam E push notifications not working

I just got the Eufycam E - 3 camera system. I set everything up, but I have noticed I’m not getting any push notifications at all. I have a Samsung Galaxy S8 running Android 9.0. I have checked all my settings on both my phone and camera and push notifications have been enabled. I was reading some other threads, and they suggested removing and adding back the cameras, restarting the base station… tried both and still no push notifications.

Base System Version: Subsystem Version:
Camera System Version: 1.9.3 Subsystem Version:

What am I missing? Please help!
Thank you.

Hello!@Munchkin Sincerely sorry for all inconvenience caused by the push notification. Could you please help to confirm whether the ‘Push Notification’ is ticked (√)in your eufy Security App (Step: Mode>Associated HomeBase>Both Home and Away mode settings>Associated camera>Tick Push Notification) and whether all cameras (or only one of camera) have (has) the issue of push notification failure?

In addition, if the model you possess is the eufyCam (not eufyCam E), please also help to try enabling ‘All Event’ in the Notification Settings (Steps: Slide the left menu>Go to My Devices>Camera Name>Camera Settings>Notification settings>All Events) and see whether it helps. If the issue still persists, could you please try contacting us via Our support staff will forward your issue to our engineer team for a further checking. Sincerely thank you for your valuable time!

1 Like

Same problem here with same phone (Galaxy S8) and eufyCam E.

Everything worked fine, then I disabled motion detection for a night and when I put it back I did not received the push notifications anymore.

I tried restarting the base 2 times (using the button at the back), deleting the camera in the app then resync it, I tried disabling/enabling the notifications in the different modes (Home, Away), I also checked that the app was allowed to send notifications in the phone.

None of this worked. The camera is recording properly when a motion is detected but is not sending push notifications.

I just tested with my second camera and this is not working either, so I guess this is a problem with the base or your servers.

I don’t know if someone did something to fix the problem, but I’m receiving the notifications again.