Eufy video Doorbell time stamp not correct

Anyone know how to correct the time stamp overlay shown in the upper right-hand corner of the doorbell’s live video feed? Mine is running exactly six hours fast. Maybe an obscure time zone setting?

Check on settings maybe

Thanks, but there are no time, or time zone related settings in the app that I’ve been able to find.

Mind posting a screenshot of the settings? Maybe you are overlooking something

1 Like

@Yo-yo Do you have any time settings listed under the settings section of the my devices section?

I am now 100% certain that there are no eufy doorbell settings related to time or time zone adjustments within the IOS app I’m using. BTW, the exact same six hour time stamp error is showing up on three different IOS devices I have the app installed on, and use to monitor doorbell video…so it’s got to be a firmware issue in the doorbell itself, or a bug in the app.

Is anyone else seeing this kind of error on the video live feed?

Advice given out previously by Anker…

Thanks for the info…however, looks like that solution is for a completely different product and app: Anker security camera (home base station), not the doorbell.

Not havi g the product it’s hard for me to find an answer.

However, have you tried to do this? Reset the country

Finally got through to eufy customer support this morning. After lots of troubleshooting over the phone, eufy rep concluded that there is a bug in the device firmware and is now referring issue to next level tech support…stand by for further details.

1 Like

Did you ever get a resolution? I have a newly installed doorbell as well with the same issue.

Eufy customer service did get back to me a few days ago, saying they had duplicated the issue and would come up with a IOS app update to fix the time stamp/live view problem within the next few weeks. I’ll post here with any new info received…please stand by.

I recently installed the doorbell cam and have the same issue. Definitely no where within the iOS app to change the time stamp.

Seems like we are the R&D team… :man_facepalming::man_facepalming::man_facepalming:

It’s really quite shameful the they would overlook such an obvious and important detail.

1 Like

Indeed. I thought I was an idiot for overlooking where it should be. Oddly enough, the time within the events it correct…just not the timestamp on the actual video, which you cannot disable. I’d say a suggestion would also be to disable/remove the timestamp for those that don’t want it there.

I was notified today that there is an IOS app update available (v1.52) through the Apple App store that fixes the 6 hour out of sync live view time stamp issue.

I have just installed the app update, reinstalled the hardware, and the timestamp issue is in fact, fixed…all is well and the problem is now closed.

1 Like

When you say reinstall hardware, did you have to remove the device from the app or will a simple power cycle do the trick?

These are the instructions I received from the Eufy customer service rep when alerting me that the app update was available:

"I’m glad to let you know that we released a new app which resolve incorrect time issue. Please update the app in App store. Then re-add your Doorbell in the app to see how it works. Steps:side menu>my devices>+ button top right corner. "

I assumed that what they meant by “re-add your doorbell” was to first “Remove Device” and then re-install it within the “Doorbell Settings” part of the app…which worked for me.

1 Like

Thanks! That worked, all good now.

Had the same problem followed your instruction all fine now. Thankyou