Eufy Spins like a top

My Eufy Vacuum spins like a top, round and round in one spot. I have tried to clean the wheels or to see if something is blocking it from going forward, but there is not… Ant suggestions

1 Like

Worlds first case of a cleaning fidget spinner, lucky. :joy: I say contact Eufy or Anker and they will surely help you out! :grinning:


There is a mode that makes it spin. Flip the switch on and off and just push the play button.


It sounds like your Eufy Robovac is in “spot cleaning mode” as @joshuad11 suggested. Here’s a link to the manual with instructions on how to change the different modes. If it still won’t cooperate, feel free to reach out to for help.

LOL @cava3395 and @nigelhealy :joy:


Hi @danny.plummer , we are so sorry to hear that our Eufy Vacuum has a problem. As @TechnicallyWell said, please check the instruction manual first, if it still doesn’t work, please send email via for help.:slight_smile:

I was wondering when someone would take this route :grin:

Sounds like your Eufy is acting goofy! :grinning:


Were you able to fix your problem danny? Mine is spinning as well and I can’t seem to troubleshoot with any success. Any helpful suggestions would be appreciated.

What steps have you taken? Did you follow the instructions to change the mode that it’s in? As always if all else fails contact

1 Like

My unit after about two months starts spinning too. I already took off the front wheel, clean all the unit but no success. And sure, I guarantee it is not on spinning mode.
I don’t live in US, so I can’t send the unit to repare or refund, it’s very frustrating.

I figure out what is happening.
After hitting a wall or an object, it turns back spinning on the right axis and then when it goes forward it continues to spin to the right because the right wheel stops working and goes back to work only with a small push. Something is happening when the right wheel stops working when spinning back that it can’t get back to work when the unit has to go straight forward.

Mine was doing this exact issue, I found a YouTube video that fixed mine. It was the sensor under the black/white roller ball - it was dirty and sensor wasn’t able to see rollers


Do you contact our team for help?

I have the same issue!! Are you fixed yours?

Does your Eufy run headlong into things that it used to see before it got there? There is a sensor on the front of the Eufy that tells it if there is something in front of it. There are similar sensors on each side. If you get the light just right you can see the LEDs as red reflective spots under the plastic. If the plastic over the sensors is too badly scuffed or dirty, the light from the sensor scatters off of the plastic and constantly tells the unit that there is an obstacle. So it spins around looking for someplace that it can go without hitting something, and fails. My fix was to polish the plastic over the sensors. I used a soft brush on a Dremel mototool to brush out the scuffmarks, but there are probably lots of ways to do it. The unit now works fine again.


My eufy wants to keeps vacuuming the same area. I’ve blocked it but it will just keep trying to get in instead of moving on to a new area. I’ll move it to another area and it just ends back up to the same blocked off spot, trying to get in. So frustrating!

Have you tried cleaning it completely and freeing the wheels of any debris that may have got tangled in it such as hair?


I was having this same trouble. I followed all the instructions to clean and so forth. It seems the bumper is stuck. Even after cleaning that it still did not work. I put it back on the floor and bumped the bumper slightly a couple of times and …IT IS NOW WORKING!!!

1 Like

Good to hear your issue be solved!:innocent: