Eufy SmartPlug Mini - Loses Connection

All my Eufy Smart Plug Mini devices (4) regularly lose connection to my home network, rendering them unusable and defeating the purpose of having them installed. When this happens (seems daily with one of more of my smart plug devices) I am required to delete the affected smart plug from my Eufy app and establish a new connection.

Many times, establishing the new connection does not always work, as the configuration process times out. This happens even though the smart plug, smartphone (with app) and Wi-Fi extender are in the same room. I often need to repeat the configuration process several times, sometimes rebooting the Wi-Fi extender, until a connection is finally established.

Unfortunately, the connections get dropped at some point later (could be a few days later), and I need to know how I can make the connections more persistent and reliable.

Here are the devices used in my network:

  • AT&T Uverse 5268AC Modem
  • Linksys WRT3200ACM AC3200 MU-MIMO Gigabit WiFi Router (Dual band 2.4 and 5 GHz)
  • Netgear WN3500RP Dual Band Wi-Fi Range Extender (for the Linksys router)
  • Eufy Smart Plug Mini (4 in use)

The AT&T modem also broadcasts Wi-Fi (2.4 and 5 GHz), but I installed the Linksys to support VPN.

The Wi-Fi range extender supports both 2.4 and 5GHz, providing a signal to the side of my home where the smart plugs are located.

All smart plugs are configured to connect to the 2.4 GHz band of the Wi-Fi range extender.

Any ideas or thoughts on how I can establish reliable and steady network connections for the smart plugs would be appreciated.

You have them hooked up righ to the 2.4 Ghz side, but I wouldn’t use a repeater (Netgear range extender). I would hook directly, via WiFi, to your main modem/router. This eliminates receiving & re-transmitting signals. Also there is a function called QoS (Quality of Service) that you can enable from the modem/router to make these devices primary. Give that a shot!

You seem to have too many wifi routers and might want to change the channels for the WiFi, also reduce on SSID, is you have too many broadcasting

2.4 GHz is the best suited for all of these smart plugs, including Eufy.

Thanks for the feedback and suggestions.

I solved the issue by connecting directly to the router’s Wi-Fi signal rather than the Wi-Fi range extender.

Although the signal from the router is not optimal (coming from the other side of my house), it is adequate enough to support the smart plugs and maintain a reliable connection.

Thanks again.