Eufy Smart Floodlight Not Syncing with Android App

I just installed the Eufy Doorbell and it works great with the Eufy Security App. But when I try to install the floodlight, I get caught in a loop in the App. After the app tells me to wait for the red light to start blinking, I click the button, and the app tells me to turn off my phone’s 4G LTE service. I click ok, and it loads up my Connections page under Settings (Android). I put the phone in Airplane mode, then turn my wifi back on, then go back to the app. The app then won’t let me go past that point. It keeps taking me back to my data settings. How do I get out of this loop?

2 Likes

I’m having the same problem. I tried dialing the LTE network on my phone as suggested in the app. Can’t in there same loop. Which phone are you using. Mines a Samsung Galaxy 9+.

1 Like

I had to call customer support to get help. What you have to do is turn off your mobile data. On your Samsung’s home screen, drag down from the top twice and turn off mobile data. If that doesn’t work, restart your phone and try it again. That fixed mine and the camera is now working great.

1 Like

Thank you. This did the trick! I was just setting it into “Airplane Mode” thinking that this would turn off the mobile data. This isn’t good enough. You HAVE to turn off Mobile Data in settings. I had to follow the following steps to turn off the mobile data on a Samsung Galaxy 9+:

  1. Open Settings
  2. Navigate: Settings > Connections > Data Usage.
  3. Tap the Mobile Data Switch to turn on or off .
  4. If prompted, tap Turn Off to confirm.

After I did this it connected easily.

1 Like

I had the same problem with the Eufy Floodlight Camera and ended up have to use a wi-fi tablet to perform the setup. The Eufy instructions were not very helpful and I could see how this issue could be a blocker for new customers without the right information and without a non-cellular device.

1 Like

Is there any way around turning off Data Saver? I’ve enabled the app to run even though Data Saver is turned on but still am unable to view live video in the app if Data Saver is on. Works fine when turned off or over WiFI. Thank you in advance.

I used an iPhone to set it up and it worked like a charm.
Earlier I tried 2 Samsung/Android devices with no luck.
I live in Australia and connected to the internet through optus router/modem/wifi device
On the device, band steering is turned off and I am using 2.4GHz wifi only (not 5GHz)
Hope this helps …