Eufy Security Floodlight

Just purchased the Eufy Security Floodlight Cam.

Cannot get it to sync to my router. Passphrase has been verified and 2.4GZ has been verified. I have even changed the passphrase to 12345 just for a quick test and it still fails.

What is broken here Eufy since the unit will not connect and there really is no troubleshooting with this unit?

1 Like

I cannot find a factory reset option for the floodlight either.

@sitedrifter congratulations and welcome to the community.
I don’t know if any of the users got a floodlight, so unable to troubleshoot your specific question. But all I can say is there is a help menu (top right corner) in eufy security app, then select Floodlight cam -> Connection- here you can find few troubleshooting instructions.
If the above didn’t work, use the live chat available in the same app or shoot an email to support@eufylife.com.

I figured it out but really it seems like a bug.

  1. I tried two wifi routers and nothing worked
  2. I tried 2 cellphones and it still did not work
  3. I tried factory resetting the unit (hold the sync button in while powering up until red light goes out then comes back.

I must have tried at least 15 times… (pretty annoying)

Then with my last attempt, something different happened and I assume this is what you should normally see happen

Once you press and hold the sync button until you hear the beep, you then click next and the app will connect. BUT, on my last try I saw a pop up message asking to change the phone’s wifi connection to the Eufy Floodlight, Low and behold in my list of connections there was the Floodlight connection. I changed it and once connected directly to the Floodlight I went back to the app and pressed next. The floodlight connected immediately to my network.

Not sure if the popup decides not to show until the 16th time or so (J/K) but really I think it is a bug. Could be a modal window issue not coming to the front of the app, I do not know but it is a bug and should be corrected in the app. Does not seem like a bug with the camera but the app. Now that is is connected, time to go mount it!

I hope someone may find this info useful but Eufy really needs to put that step in the booklet of instructions. This way, if users do not see the pop up they know something is wrong!!

SiteDrifter

3 Likes

Glad worked for you finally! And thanks for posting your findings here to benefit other members.
@AnkerOfficial may want to convey to eufy staff to clarify the settings.

Same issue. when connecting the app is telling me to set phone to flood light network but its already shows as being connected to it. thought I saw something in the brief setup document about the the phone and the light need to be on same network?? very confusing and frustrating and I’m tired of going up the ladder to push the reset button

My phone switches to the floodlight network, then my home WiFi, but the camera refuses to connect, any suggestions?

Support told me that there is a bug with the iPhone app, used an android device and it worked first time!

I still cant get mine to connect - and we are fully apple here and have no android devices.

Anyone with any work arounds?

I am connected to the floodlight_eufy wifi network on my phone, but when I go back to the app, there is no way to tell it I am connected and it times out. I have attempted this a few times now. How to I move forward in the install process??

Hello @westonmoore I don’t own a floodlight so not aware of the connection process as it looks different than other eufycam/doorbell series.
Contact support@eufylife.com they will help you troubleshoot the issue.

Alternatively, you can post any questions or issues on eufy security forum so you can get some help :slight_smile:

1 Like

Id like to thank you for saying you need to change to floodlightcam on your phone.
The option to change wifi kept popping up and I thought it was more of “are you sure youre connected to your wifi” type of thing. I had to view more in order to see the floodlight.

Someone needs to fix the instructions for this.

Im now having another issue where after this, when the app says floodlight cam is connecting to network… it doesn’t connect.
I have VPN on my router if that happens to be an issue.

Edit: Just a heads up for anyone. Turns out having a VPN is an issue.
I was told it has to ping a server and it also relies on accurate location information for the geofencing feature.

thanks for posting this, it worked for me. wifi was the same for both but cam dropped out and couldn’t refresh.
noticed there was “floodlight cam” listed as a “wifi source” (it isn’t) but once i connected my phone to it, the cam responded and reconnected. odd tho that my phone says it’s connected to the home wifi, not the camera…

this is a bug that should be fixed.

Make sure you turn off data on your phone during the setup.

Took me awhile to find that out.

1 Like

You are absolutely correct. I tried to connect floodlightcam with data ON and it just does not work… The moment I read your comment & turned the data off it installed in 1 sec.
Thank you

1 Like

Just bought a Floodlight Pro2 All was good until it updated Made it to 100% then said update failed
Since then App is stuck in “Camera is updating” loop

I’ve tried setting up with a different account adding new device but now it cant see our WiFi which it did the 1st time when it updated. Cant delete the device as stuck in loop.

Thinking it may have to go back as haven’t seen the floodlight WiFi some people go on about
Funny how the reviewers never have these problems Lots of different routers and phones out there.

In contact with support so will see where that goes

Pejo