Eufy Security App missing in play store

I can’t update the app on my tablet
The Eufy Security App is now missing in play store on my android tablet and in Bluestacks.
It shows up in the play store on my android phone , that’s all working good.
Looking on the forum, I see this has happened in the past with Eufy, I also had the same problem with another brand of cameras before

1 Like

I see it on my phone (Pixel 3), running Android 11

1 Like

What version are you on?

What version are you talking about Android OS version or eufy app version?
This device S9+ is android 10 , Eufy app v2.1.2_708, there is no problem on this device

Samsung tablet is android 7.1.1, Eufy app v1.9.0_646 on this device the app is missing in the play store so I cannot update it.

This device , Fire8 HD with playstore installed , Eufy app v1.9.0_646, the app is missing in the play store
The app is also missing in the play store in Bluestacks.
This device, Samsung S7 android 8.0.0 , has Eufy app v1.9.0_646 because I have not updated it yet, but there is no problem with this device, Eufu security app is showing up in the play store.

I had this same problem with the wyze app before , it was not an issue with my devices or settings and there were many people with the same problem , they did get it fixed, how they fix it I don’t know.
I searched this forum and found Eufy had the same exact problem in the past

Go to this Link
from said device and download the APK. Once downloaded it will ask to allow permission to be installed from unknown source, allow it and install the update.

The issue is compatability with older Operating systems and functionality, if its not available in the app store then it generally means there are functions that have not been verified to work or function properly on that specific operating system. Generally jn these instances people will source the APK file and side load it that way to have the most up to date features even if it can cause issues

This is not the case here, 3 hours after I posted the last post here, I checked and find that Eufy had pushed out yet another new app v2.1.3_713 , the issue has been resolved on all of the devices that were having the problem with the app missing in the play store, they are all showing up as an update and in the play store with this new app.
I did go and look for an APK file day before yesterday, but the newest app was not available , the latest one they had was 705 and that’s the one that was screwed up with different problems, they did not have 708, I’m going to guess you wouldn’t find an APK file for v2.1.3_713 right now either.

I have to say they did a pretty good job of fixing the issue pretty quick :smiley:

The same happened to me with my Samsung Tab 2 running Android 7. I noticed this because my cellphone with Android 10 updated the app automatically on Sept 17. The update fixed problems including inability to save recorded clips from live view.
I tried to manually update the app on my Android 7 tablet but Google Play showed “this app is no longer compatible with your device.”
I notified and they immediately sent me a link to a compatible version of the app. This worked ok on my tablet. I was told that a new version 2.1.3 will be released in a few days.

1 Like

Yeah ,they already pushed out the new app to everyone