Eufy Security Alexa Skill not functioning, code error.

All cameras i have in my Alexa environment work fine, except for these ones. I’m pulling my hair out ‘Sorry ## is not respoding’. It took me a while to figure out why and I think I have, but there’s no way to fix it. The problem. Clicking on the camera device in Alexa app you get a run down of info on each camera. There’s a section that says how it links, some of my cameras use Tapo. So if i click on these other cameras where it states the linking app name (long press) it brings up the Alexa services running on the camera. under advanced, and capabilities. There’s Alexa, Alexa stream controller (which lets it views the stream) and the most important one, Alexa.EndpointHealth. This tells Alexa the device is ready. THIS IS NOT RUNNING, THE EUFY SECURITY APP IS NOT MAKING THE CALL TO ALEXA VIA THE SKILL SO THE CAMERAS SHOW UP BUT ARE NEVER READY. FIX THIS DEBACLE PLEASE.
UK Eufy Cam 2, latest firmware on all devices, tried resetting all devices twice, gone through all that stuff. Oddly for the first day it worked fine, then nothing, that was 3 days ago. Considering returning it.

1 Like

I think its a known problem. I never can use the EufyCam with my Alexa show. How hard can it be to fix that issue?