Eufy robovac teansition from hardwood to carpet problem

My Eufy Robovac has recently begun to have difficulty transitioning from hardwood floor to carpet. Why is this happening after months of successful use and how do I fix this?

You could make a video and show us.
This would be very helpful.
Thank you.

May be it caught some hairs. Try and clean the brush.

distance diagnosis’ are not easy.
He should take a video, as I suggested, but … :wink:

Have you tried deep cleaning it when opening it?

I have an older model that had this issue and think it will happen again. For me I ended finding all sort of dog fur wrapped around the brush and the wheels. Once I removed the fur it worked fine. Since I was servicing the unit, I went ahead cleaned the dust and finger smudges from the sensors and replaced the batteries in the remote.

After all these updates the unit started running better.

If that doesn’t work take a video and contact Eufy Support.

Hair trapped in brush is typically the most common issue with vacuum’s poor performance.
Recently I cleaned my Dyson DC40 and found a ton of hairs trapped in the brush. Had to remove the brush assembly to clean it.

Claro, no clean brush no clean floor! :grin:

Maybe also replace the spinning brushes on the front? I ha e seen those give my 30c trouble on transition.