Eufy Robovac 30 Red light

So I have a Eufy Robovac 30. It still works well and everything, but, Ive found a issue. When low on battery its going back to the charger itself. Starts flashing orange indicating it’s charging. It will then do a variety of things, switch between a orange flashing light (almost seems like it’s charging, then not, then charging, but if you take it off the dock light will turn blue) and a solid orange light, or after charging with a orange flashing light for a short time (30 second) will change to a solid red light. I’ve cleaned the Eufy, checked all brushes, checked charging points are clean. Nothing seems to resolve it. Only had it since August 2019.

Thanks in advance.

1 Like

May be a “reset” would help.
Open the battery case take off the battery for 30 secs and connect it again.

1 Like

Let’s give it a go :slight_smile: thanks.

I’m afraid that didn’t do the trick. Alternating between a solid orange light and a flashing orange light at the moment. About 30 seconds on each.

Meanings of Indicators

Off: No indicator
Breathing orange: Charging
Solid blue: Standby / Cleaning / Fully charged
Solid orange: Low power and returning to charging base
Flashing / Solid red + Beeping: RoboVac has an error (this is your case - error)

Do you hear any beeps when the indicator is solid. These are the meanings of red indicator light when it is solid:

One beep = RoboVac’s left/right wheel is stuck. Turn off RoboVac and remove any hair or debris from the left/right wheel.

Two beeps = RoboVac’s side brush is stuck. Turn off RoboVac and remove any hair or debris from the side brush.

Three beeps = RoboVac’s suction fan is stuck. Turn off RoboVac, then remove and empty the dust collector. Make sure the suction inlet is not blocked by any hair or debris.
Four beeps = RoboVac’s rolling brush is stuck. Turn off RoboVac and remove any hair or debris from the rolling brush.

If the above does not help, reset is the option as suggested by @Chiquinho

Also contact eufy customer service team via:



EufyHome app->Help->Contact Us->Feedback/Chat/Call us

Hi Shenoy,

No - there are no beeps. It starts charging the normal way, with the orange light flashing, but then after 30 seconds or so goes solid, with no beeps.

I will contact eufy support.

Kind regards,

Ja, you should contact the support, because its warranty covered.

If you can, do let us know how it resolved at the end to benefit other users. Thanks!

Hi all,

Just to state this has now been fixed.
Instead of sending out a whole new unit, eufy sent out a new battery to see if that would fix the issues and luckily it seems to have fixed it! I just need to check when I’m home if its worked properly after a full use and if it charges back up correctly, but on initial testing yesterday it did charge and the blue light came on. Thanks.


Yes this could be a good solution for all.
Let us know if all is perfect finally.
Good luck!

Thanks for posting the update! Keep us posted how it works and if it stays stable

Hi all. Unfortunately I am facing the same problem with my Robovac 30C and Eufy Spain (bought from Amazon) won’t even recognize the problem. I bought the Robovac 30C in February 2019 and they claim that I have to prove it is their problem. Apart from that they don’t even offer me a solution to buy a new battery or anything. I did not expect such customer service.

*Just to clarify, in Europe all sellers must provide 2-year warranty.

You should insist on a solution regarding the warranty period.
May be the “service” differs a lot from country to country.

Well I hope an administrator will see this post and take action. It is not accepted for a device to have such issues in short time and with minimal use. I did take care of it and always had it clean once a week.

1 Like

It was a perfect idea to open such a thread here.
The forum is the place to publish such things.
Lets see and hope.

Um grande abraco