Eufy Robovac 25C Connection Isuues


I’m hoping some of you tech’s out there can help me out.

Moved into a new house and setup spectrum and tried setting up my brand new in box Eufy Robovac…had it for awhile, never been used, and no luck hooking up my new vac. I downloaded the app, tried setting it up but it can’t seem to connect to the Wi-Fi? The app will find the device but when it’s on the Wi-Fi list, it’ll show up but won’t connect?

My guess is that my router is only letting out 5ghz? I need the 2.4ghz for the robot. I’m not sure how to change that. I looked up everything I could on how to setup this and change settings. When I type in my ip settings into a browser, it just tells me to download or scan the spectrum app. Which I have and nothing in there access my IP settings.

The router is: SAC2V1K
Modem is: E31T2V1

If anyone could help, be greatly appreciated!

Thank you!


Unsure how to help you on how to connect to it though.

I know for my nighthawk router is duel band. It has 2.4 an 5 g. When I go to connect I get the option of

Netgear 5g 1
Netgear 5g 2

The first one is 2.4 and the other two are the 5g.

If when you look at your internet connections that you do not see anything similar, I am unsure how that device will split that signal.