Eufy Robovac 11s Max issue

Eufy 11s Max Issue

Curious if anyone has had the solid red light with 3 beeps issue? And how did you fix it? I see this is related to the suction fan/intake. I cleaned all the brushes thoroughly. The dust filter is basically new. Still get the red light and 3 beeps.

So I replaced all the brushes and filter with brand new ones. Made sure there was nothing blocking the intake. Still same issue.

I almost gave up and just decided to use a can of air to blow into the fan to see if that freed it up? Well, it looked like it fixed things since I was able to run it longer then the previous two times with no issue. Decided later that night to use it and the issue cropped up again and at this point im clueless till I can talk to CsR after the weekend is over.

It’s barely 4 months old. Its not used that often. Ive made sure to clean it before each use and emptying everything out after. I just want to know if there is anythjng I can do on my end that can fix this before I have to send it in.

Really regretting buying this one to replace my deebot n79s.

Hopefully someones got some answers here.

1 Like

Hi @HomeBase6
Shame your having problems.
I have the 11s (not Max) and love it.
A red light and 3 beeps means the suction fan is stuck. Turn off, then remove and empty the dust collector. Make sure the suction inlet is not blocked by any hair or debris.
That solved my issue when i first got it as i completely overlooked the fact i had to empty it regularly. normally gets back to you pretty quickly. They got back to me yesterday (Sunday afternoon) with just a general query.

Keep us updated with your progress.

Think you should write a email to the support, as you have done all possible.
Last attempt : open the battery case, unplug the battery and reconnect it.
This is a kind of hard reset to the mb.

1 Like