Eufy Robovac 11s having trouble docking

My Eufy has worked great for nearly one year and had no problem returning to the dock. It could even maneuver behind the couch and dock just fine when I had temporarily moved it. But I had it turned off for about two weeks, and since turning it back on, it is having trouble docking. It will go to the dock, almost dock, then turn, pushing the dock, and can’t get reoriented again. Even if I place it right in front of the dock and hold the dock in place, it does the same thing, looks like it’s going to dock just fine, but then will turn and shuffle around endlessly. I have tried turning it off and on again, and unplugging and re-plugging the dock. But it still can’t dock properly. Any suggestions would be appreciated.

Try wiping down the front of the sensors with a damp cloth and then dry it. Mine does that occasionally when the sensors get dirty

1 Like

And if the cleaning of the sensors, Rob mentioned, will not help do a reset by removing and inserting the batteries,

1 Like

Ah, Yes! I had to do a combination of cleaning the senors and removing the battery! This seems to have solved it! Thank you!

Thanks! That helped! I had to do a combination of removing the battery and cleaning the sensors.

Perfect that you got the issues fixed!