Eufy RoboVac 11 Battery Failure

Bought my Eufy RoboVac in June 2017. I use it twice a month which means that is has been charged 36 times. After every use, I cleaned out the dust bin and used a shop vac to clean dust from the brushes and moving parts. Battery no longer holds a charge. Disappointed in the low quality battery. I would expect a minimum of 500 charges.

Out of warranty probably. I cannot find what is the warranty.

email and see if they can an out of warranty repair?

This video is not of Eufy Robovac but a similar looking device and if Eufy is as simple it looks like not too challenging to replace the battery.

I have replaced non-Anker product batteries it was not difficult if I could find a video guide.

Eufy offers their Robovac a 12 month warranty, but as Nigel mentioned reach out to support for assistance

It is easy to open the battery case and remove the battery,
so you might check the battery.
If its broken you may find replacement very easy.

I bought the $30 replacement battery on Amazon, Part Number: AK-848061065053. Two screws to open the battery cover and a plug connector. The Eufy robot vacuum is now working.


You see, quite easy! :grin:

not with eufy robovac 11+, it dosent have any access to battery pack. contacted the eufy but no response yet

Recently I bought Eufy RoboVac 11s.
Since the day I started using it I noticed some beeping.
It occurs when battery is charged and it is getting closer to fully charged.

Behaviour as follows.

I use the Eufy RoboVac 11s to do the cleaning.
Return it to the docking station to charge.
Orange light will blink while charging.
No beeping while charging for about couple of hours.
About 2.5 minutes before fully charge(blue light comes on), it starts beeping 5 times with solid red light on.
This 5 beeping goes for three times then stops.
Then orange light start flashing for another minute or so.
Then repeated the three 5 beeping with solid red light.
Then orange light start flashing for another minute or so.
Then it light become solid blue, stating it is charged.
No more beeping beyond this.

Things I tried,

Cleaning the contact points for charging.
Removed the battery and waited half an hour and put back in.

Non of the about resolved the issue.

Is this normal behaviour or is this means my brand new Eufy Robovac 11s got a faulty battery?

Could you please advice on this?

Its not normal at all.
By removing the battery for while and insert it again you did a reset.
But the issue remained, so you should contact the support.

I had a similiar problem with my Robovac 15C. However, i think the main problem was the deep de-charging when me parents left for vacation. The battery still worked, but with the 5 beep red error. I just bought a new 30 EUR battery and now everything works fine again.

Thanks everyone. Yes, contacted support waiting on them. In the mean time, I did used it till it discharged (about 100 munities) and guided it self to the docking station. Seems that fixed the issue. No more beeps. But will keep eye on it. Cheers.

100 minutes is not so bad.

Is this the working time-span with the lowest suction?

Yeah, I ran it on lowest suction till orange light flashing and it was looking for the docking station. Total time roughly about 90 to 100 minutes. So I think it may had to “recalibrate” the battery as it was only beeping near ending of the charging. Or worst, battery will fail in the future. Let’s see how it goes. Still no reply from Eufy Support.

Needs a little bit to get an answer.
Be patient.

Update, beeping is back. Today ran it till orange light blinking. Just before it fully charged as I described early, it beeped with solid red light.
Only support reply I got is from their “eufy AI Responder”. Replied to that as per instructions on the email, and still waiting.