Eufy Remote not working for robovac 11

I’ve tried everything from changing the batteries in my remote to resetting my eufy at the on/off switch. I love my eufy but all of a sudden I cannot remotely control it. It needs to be switched on manually and cannot be controlled by remote control. I’ve tried everything from doing a schedule reset, where I pressed the schedule button 3 times and holding it for a few seconds on the remote control. Still not working with remote control.

I removed the bumper cover and removed all dust from the sensors, still to no avail.

To restate…

The eufy works when switched on manually, but cannot be navigated or no instructions on remote control works. Making it clean manually and randomly.

Please assist.

1 Like

As far I see, you have all done you could…
Cleaning, resetting Vac and remote …

Hm, for me it seems the remote is really defective.

Did you contact the support?
Do they have any ideas?

Did you install the battery in its proper orientation? I know is seems like a small thing but can be overlooked when frustrated

Yes this could happen, but there is a " dead display" if so.
But you are right!

Hey @Moegsiem
Shame you are having problems.
Sounds like either the remote or the IR sensor on the vacuum is faulty.

A great way to test an IR remote is to point the IR end of the remote at your phone camera and repeatedly press buttons - don’t hold the button as it sends only once.
If the remote is working you will see the IR diode flash white.
It will be very faint and will appear where I have marked this photo.

If it doesn’t flash, you can buy a new remote.
If it does flash, it’s likely to be the vacuum.
Make sure the IR sensor is free from obstruction, the sensor hides behind the bumper bar as marked in the photo.

Keep us up to date with your progress.

2 Likes

That’s a good idea for a testing. Paul.
Great!
(Didn’t know that)

Learning tough so old! :rofl:

1 Like

I learned that many years ago.
Its interesting what you remember and what you forget :grin:

1 Like

Thanks for the response Chiquinho. Yes, I contacted support and they did could not come up with a viable response…just said I should consider replacing the remote. Problem is I’m in Cape Town South Africa, and there’s no support centre or accessories available here.

The batteries in the remote…yes. the battery in the robovac…haven’t touched it. Maybe I.should just open the battery holder and see 8f all connections are okay…thank you

Thanks for all the advice guys… I extensively cleaned all the sensors and haven’t tried IR diode flash trick. However, when I press the remote it changes functionality on the screen from say auto to .schedule to home. Just seems it doesn’t link to the robovac machine

1 Like

Alles klar : :smiley:
Using Paul’s trick you make sure the contact of the infrared is working.
That could be really the problem!

Greetings to Cape Town from München!

1 Like

Hey @Moegsiem
Ok, so it seems its likely to be the remote.
Looks like you can order from Amazon for shipping to SA.

https://www.amazon.co.uk/dp/B07WGHBZ5W/ref=cm_sw_r_cp_apa_fabc_Kv21FbK7RB8ST?_encoding=UTF8&psc=1