Eufy Light doesn't connect

I had a Eufy Lumos light that was connected fine. I had a power outage for a number of hours and when it came back on I have 2 lights that are not longer connected. I have attempted to reset them multiple times and they reset fine. They are also seen by my iOS device, but when I attempt to add them it always fails. I have a Linksys router, which is the same router I had when I connected them originally. Any help would be appreciated.

Are you able to see the Eufy_Lumos_xxxxx on settings off your iPhone after reset of the bulbs? If not then the bulbs may have issue. I doubt it since both bulbs cannot go bad at same time… But it is a possibility, things happen.

If you see the “Eufy_Lumos_xxxxx” in your Wifi Setting on iOS, proceed to below –

These Eufy Lumos light bulbs need 2.4GHz WiFi. Can you make sure there were no changes on the Linksys router and 2.4Ghz WiFi is available.

Also make sure the iPhone, Lumos Bulbs are close to the wifi router when you attempt to add it to Eufy App.

One last thing to try is - if you have a spare Android phone, try to add it from that. Worth a try.

Also try reaching to Eufy Support over email or from the Eufy App.

1 Like


Yes after they are reset I do see Eufy_Lumos_xxxx in my Wifi settings. Everything seems to go ok with adding them to the network right up until it fails.

There is a 2.4Ghz network available on channel 2. However, it is the same SSID as the 5Ghz network. That was how it was setup before and operated without issue.

I did separate out the networks to XXXXX & XXXXX5Ghz and still the install failed.

I did also send the same message to

Please try with Android device, if and only if possible…

I had the exact same issue, adding with Android worked. Once adding was done from Android, was able to control from Eufy and Google home.

Believe it’s something to do with the iOS version.

One other thing to try on your iPhone would be turning on Airplane Mode, then enabling WiFi only (in effect, turning off Bluetooth and cellular data). This may help cut down on any possible interference.

1 Like

Eufy has pushed a newer version of EufyHome app v2.3.5-3 today with bug fixes. Try updating the app on iOS and give it a try.

Have You found solution? I have just bought 3 Lumos Smart LED Bulb Tunable White and cannot connect any of them. Tried different wifi, restarted many times, eyfyhome reinstalled and tried to connect with Amazon Alexa - no success. Still cannot connect device.

Contact support

Does anyone have a bloody solution to this? I bought 6 bulbs and i have exactly the same problem. cannot connect.

i have set the wifi to 2.4, tried multiple devices and a second router. still no luck.

i can reset the bulb, flashes 3 times, can see its own wifi network and after 99% it says fail to connect.

i even used very old versions just in case.

please assist, im hopeless…