Eufy homebase (T8807CD3) wifi stopped working

I bought a eufy 4 camera security system from Amazon about a month. Setting up was easy; I configured wifi and the system was working fine. However yesterday in the evening, the the system stopped working, saying that the homebase was offline. I brought the homebase to the router, connected it with the router with ethernet cable and restarted it; the light became a solid white and system was back online. I checked in the app to ensure that the wifi was still configured, and then pulled the ethernet cable out. I expected that the homebase would switch over to wifi - but it did not.
I spent about one hour last night - turning homebase off, turning back on, but nothing worked. I tried to reconfigure wifi; it correctly sensed all the available networks. I selected my network, re-entered password, but finally got the message - homebase cannot connect to wifi.
Can anyone tell me what should I do?
The system version is:
Subsystem version is:
(No firmware update has taken place since installation on 1 Nov and it is upto date.)

Surprising. I pulled the cable out last night, and it worked !!!