Eufy homebase 2 not connecting to wifi after update

Hello everyone

today I had an Eufy homebase 2 update. this requires to re do the setup of the device.
When I try to perform the setup the Homebase constantly says “please follow the instruction on the app”
I connect the homebase by wire to my router and the blue light comes
when I scan the QR code the light come directly to red .
few moment afte it comes blue again and says “follow the instruction blablabla”
whaetever I try the homebase is refusing to associate.
is the new firmware having breakin gthe home base ?

thanks for your help

Hi @Neneche,

We may need a bit more information to locate the issue.
Please contact us at with the issue description and your serial number.
Our service team will get back to you within 24 hours and will assist you step by step.

Thank you for your understanding.

Best regards,
The Anker Community Team

Similar problems here:

I have a Euyfy Home Base 2 that updated its firmware yesterday to

The result: all camera’s are disconnected.

I have hanging 3 camera’s (type: Eufycam2) and 1 Eufy Battery Video Doorbell.

I had unpacked 2 more Eufycam2 that I wanted to install coming weekend, so I put them charging.

I have had a lot of trouble getting the HomeBase2 working again. I had to uninstall all connected camera’s and the HomeBase2 itself.

It is a big difference compared to installing from the box over a month ago.

Reoccuring problems: no internet connection (I have both ethernet and wifi connection, the wifi connection it remembered from the 1st installation so it seems). It often says it is not connected.

I am unable to connect one of the new camera’s. I try all the steps in the app, but it always fails.

One time I get one beep while trying to install, sometimes 2 beeps. But never I can install.

I have heard HomeBase2 say it was going to connect and sound the several beeping sounds, but the app shows that it could not connect and it was past the whole procedure on the app that the HomeBase2 sounded those beeps. Usually it does not even go that far.

So my question: can I downgrade to a previous firmware when everything was working okay and set up that I do not want new firmwares in the future.

I am about to go on holiday and leave the house, this is absolutely the wrong moment for a non working firmware that messed up all my Eufy Security.

Can you help?

I have already emailed this problem to but posting it here, as more people might have the same problems with the firmware update.

Problem I wrote about in previous post seems to be solved.

Although the firmware caused all cameras to be offline,and I could not install camera’s anymore. Now I can.

What seemed to be the problem?

As I was waiting on the new firmware that should make it possible to store video on an external USB stick connected via the USB connector, I already put in a blank USB stick.

Tonight I took that empty USB stick out and I could add 2 camera’s with no problem. Even the app reacted differently then before.

Thanks for your attention.


Me too I had a usb stick in the homebase to record the video
I unplugged the homebase for a night and also the usb stock and the day after I finally get the homebase working
I had to reinstall everything but seems working for now
So if you have a usb stick try to reinstall without it

Glad to have found this topic! I had the same issue and I too had an USB pen drive attached. It was not clear to me at the time that removing that drive was key to resolving the issue, as I changed and tried a lot of things. Removing the pen drive was part of last efforts and preparations for sending it in for warranty.

As the homebase is installed in an inconvenient to reach spot I had a 128GB USB pen drive pre-installed because of the announcement by the in-app help text, explaining coming support for USB storage devices.

Symptoms are in line with the others in this topic: the whole system stopped working after firmware update. The Eufy Homebase was happily calling introductions and invited me to install the system. It would not let me pair devices. The LED would turn blue, go red and repeat over and over. It was very slow in the app and not responding entirely during the red LED cycles. The pairing process would come up but did not produce the “digital sounds” and asked me to check for internet connection. During troubleshooting the recordings stored on the device where lost, as I tried a hard reset.

I saw no one complain on this forum during the first hours after the firmware update and I thought that my device was somehow damaged during flashing the update.

Hopefully the findings in this topic are reviewed at Anker and the testing process will include use cases with occupied/connected USB port.

These symptoms sound very similar to when booting a windows PC that has a USB “stick/drive” plugged in that cannot be booted from in that the Windows PC keeps trying to boot from a “bootable disk drive” but cannot until you remove the USB “stick/drive”. As far as I’m aware, the use of an USB drive is not yet supported on the HomeBase 2 (T8010)

I got the same issue this night (around 4 am) where the homebase was trying to connect to network and could not
I had to unplugged the homebase and remove the usb stick
This morning I had to redo the installation from zero …
so I think that the usb capability is seriously not supported
And is there a way to shut up the nice voice of the lady ? Because being awake by her nice « trying to connect to wifi » at 4 am is not my prefered thing !

Good morning!! I received this message on my accounts. I can’t access any of my cameras and I don’t know if my property is secure.

Any insight would be beneficial.


Thank you very much for the help! I had the same problem but sorted out with the solutions provided.

As far as I am aware, the USB storage capability has not yet been made available on the HomeBase 2 (T8010). It only has the 16Gb eMMC storage capability.


That is my understanding too.

My home base 2 seems to be connected. I’m not sure how to access the recorded video?

To display the videos of previously recorded event/s:
Open Eufy Security application
Select Events (clock like symbol at bottom of screen in the middle)
At top of screen, select the date using the < or > symbols either side of the date shown
Near top of screen select All (to show stored videos for that date plus logged Alerts) or just Video
Select the required video (in descending time order) to play it

To display what each camera is currently seeing:
Open Eufy Security application
Select Devices (house like symbol at bottom left of the screen)
Find the camera to view and select the play symbol
Select the back arrow at the top left of the screen to end current viewing session.
Note: the last image of the just played session remains until the next time you use this feature.

Also join the the Eufy Security Camera Owners group on Facebook for helpful information