Eufy Floodlight not conecting to Wifi - SOLUTION

Finally, I figured out how to get the floodlight to connect with WiFi in Australia!
(Select that you are IN America, when setting up!)

ALSO: I HIGHLY recommend setting up the floodlight with a “suicide line” (get your electrician to install this for you) BEFORE mounting it up a wall, because you will press that reset/sync button at LEAST 100 times and it is much safer doing so, on the ground.

I had tried EVERYTHING possible to connect the floodlight, including:
All of the instructions in the app and the app’s help section
Turning the phone on aeroplane mode
Tried with no sim inserted in the phone
Tried with Bluetooth and data off
I have disabled all 5ghz connections so my router only has internet at 2.4ghz
I have reset the floodlight
Reset the app
Tried from a different location (America, and Outside America)
Turned it off and on at the power again, and again… and again
I get past the white flashing light and then wait more than 2 minutes and it gives me a tone from the light itself and says on the app, can’t connect to WiFi
It tells me to turn data off, when I don’t even have it on
I have also tried it on different devices!

The way I fixed it was:
Open your router settings and turn off band steering from your original 2.4ghz WiFi settings.
Enable your “Guest” WiFi account.
Create a Guest WiFi name and password (slightly different from your normal one, so you can tell the difference at installation). I made the mistake of naming my WiFi “test” and had to go through so much trouble to reconnect the floodlight, so don’t make the same mistake and name your guest account something you’ll never change!
Continue following the app’s prompts to set up the account.
Viola! The camera will connect!!
I turned band steering back on once I had completed the setup but unfortunately, I now have to keep my guest 2.4ghz WiFi on, meaning we will always have two visible WiFi accounts.
Ahh well, at least it finally works!!

Good luck!!


Hi Steff,
Thank you for the feedback and sharing your experience to make the floodlight cam work!

I think the issue is caused by the router’s band steering function.
Some routers may have the band steering work like below:

  1. It detects the client signal strength. If the signal is strong and the client is on 2.4GHz, the router will think the client is close enough and try to push it to a faster 5GHz Wi-Fi. So the router kicks out the client and forces it connect to 5GHz.
  2. If the client is a 2.4GHz-only device, which is the case of our floodlight cam, it can do nothing but try to reconnect back to the 2.4GHz Wi-Fi.
  3. If the router doesn’t mark the floodlight cam a 2.4GHz-only client, it will continue steering the floodlight cam until it times out.

So I think creating a guest Wi-Fi without band steering feature definitely helps to solve the issue. Meanwhile you can continue use band steering feature for your dual-band enabled clients.

Mate I am also in Australia and have tried EVERYTHING to get this to connect. I am with iinet and have a TP-LINK router. I dont have a band steering function but turned off my 5G network but no luck. Must have reset the thing about 100 times. It connects to my phone straight away. Any suggestions?

Hi Steff,
Many thanks for your post. You are a life saver. I experienced the same issue with trying to connect to my Telstra Gateway modem.

Similar scenario, Telstra smartmodem, floodlight connects fine to Guest vs normal profile. I do not have band steering on. Can only connect to the Guest (and 5Ghz channel is turned off completely on the router). Unfortunately the logs dont show the interaction but no idea why it would be facing any sort of band steer. It connects fine to synology routers i use inside for mesh. Something particular with the Telstra modem.

Thanks for your information.
I have the same problem. I try your way but it didn’t connect to wifi. My router is Teltra smart router GEN2. Any help, please?

I have the same problem. It didn’t connect to wifi. I try this solution but no working. My router is Telstra smart router GEN 2. Any help, please?

I called Customer Support. They had me turn off mobile data and the eufy app paired with the floodlight and prompted me to give wifi network credentials.


Hi - I can confirm that the solution outlined by westonmoore works.

1 Like

Turning off mobile data is the big winner solution.
Have to keep in mind a few other things:
Must sync the floodlight to a 2.4G network. It will NOT work with 5G.
Have to log your phone into the 2.4G wifi before you begin.
Also, if you happen to use a VPN on your phone like I do, you have to disable the VPN to get this to work. Wasted over an hour until I figured this last step out.
Now the floodlight is finally connected.

I’m beat.

I’ve got a Netgear Orbi dual band 2.4 & 5Ghz router (no satellite currently set up) and just can’t get my floodlight connected with an iphone.

As you can’t switch band steering off on an Orbi (and firmware has removed a hack to create separate band SSIDs using Telnet), I’ve tried:

  • my mobile on 2.4 G band, with power to the floodlight only turned on after the 5G SSID is off and 5G transmit power to 25% (no other devices right near the router would connect to 5G band); and
  • mobile data off

I can’t even get my phone joined to the floodlight cam wifi network through the setup at the flashing white LED stage - it tries twice, says it can’t and prompts to select the eufy cam network through my phone settings… but that doesnt show in the list of available networks.

I’ve had no showstopper problems getting the Eufy HB2 added to the network (for 2C and wireless doorbell cameras) or other 2.4G-only devices connected on the Orbi. But am stumped on this one after trawling a lot of various forums/threads.

There’s not a tonne of 2.4G network traffic at the floodlight, and even though it’s about 10-15m from my router (I know Eufy recommends closer), my phone on 2.4G still gets good wifi reception down/upload speeds at that spot.

Anyone got an Orbi to work? Any other suggestions warmly welcome, other than buying a new router!

1 Like

Am in Australia too - I bought 4 of these cameras to replace existing floodlights. The guy who served us said to go home and run a 5 Min YouTube video via wifi only in each camera location, before we purchased to check our signal would be strong enough - good advice. One of our cameras has a Model No of T8420 and the other three have Model No T8420X. The first one (T8420) was very easy to set up by scanning the QR Code on the top of the box and connecting to our wifi. The other three have been no end of trouble over the last three days trying to connect them. The QR Code on the top of the boxes does not work - if you scan the box, the app continually looks for “FloodlightCam-Eufy network’ to connect to, which does not exist. After trying everything I could think of multiple times - turning off 5ghz on the modem, turned Band Steering off, inputting QR Code manually, turning power/phone/modem off and on again, what finally worked is scanning the QR code actually on the bottom of the camera itself. It appears there is an issue with the QR Code on the box for the T8420X model cameras sold in Australia - apparently the X model allows you to set detection for humans only. So now they are all set up and we are happy with the clarity of the view, night mode and the controls available in the App. There is no subscription required so that is another big plus with EUFY.

1 Like

Hmm - none of this is working for me. Technicolour DAW0120 with some Belkin range extenders.

Have tried (i) main network and guest; (ii) 5G on, with band switching off; (iii) 5G off altogether (EUFY app cannot even see the networks, under ths option); (iv) range extenders on / off (makes no difference). In each case, my phone has been connected to the correct network, with mobile data off and no VPNs. None of my other devices have any difficulty connecting the networks in the foregoing scenarios - so presumably its the floodlight that has the fundamental connectivity issues.

Any suggestions are welcome.

You can ask your questions at the EUFY forum as well.
May be the friends there can help you.

Thanks! Will do.

I have been having issues as well. Cant find the answers on the other forum so thought would post here.
My wifi wasnt strong so bought powerlines. Wifi is good now. Trouble is prior to this the camera was showing up on my phone but wasnt connecting , now it doesnt even show up on my phone when you get to the flashing white light etc etc…have spent over 500$ for nothing by the sounds of things

I too had the same problem. If you tried all the other steps, try these simple step ( Hoping that you are on 2.4 ghz network)

  1. Phone ( eufy app is installed): disconnect the existing home wifi network by doing forget the network .
  2. Do the Common the steps suggested by eufy app
  3. Add the existing network with password
  4. name the camera. But you may experience issue going to the step after naming camera. Name and keep the eufy app as it is
  5. connect wifi in the normal settings
  6. come back to Eufy app setup and apply next.

Thats all, rest you should get naturally. Good luck. Now I am playing with Alexa skill creation

I too have the same problem. It just will not connect to my wifi, while all other cameras, devices, doorbells etc. had no problem.

Here is my solution: Turn off your firewall during the setup process.

I use the OPNSense installed on a Protectli. I had to create a wifi access point outside of Protectli. Once I did that, the floodlight cam can quickly go through the setup process.

Once it is setup, however, you can move it back to the wifi that sites behind the firewall and it will continue to function.

Hope this helps.

1 Like

Nice comment

It all depends on the setup and how the specific the wifi works.

I hope this helps other users who face similar issues