Eufy Floodlight Camera Solid Red

Camera and lights worked fine for about 36 hours. This morning, it recorded its last motion detection as I left the driveway. I could never get the camera to broadcast a live video afterwards. Lots of wind in the area today so I thought maybe that was the problem, but I could still control the flood lights with the app. Every time I attempted to see a live view I got the “Unable to play live video” message after about 30 seconds.

I then removed the device from the app and tried to start the setup from step 1. I have not been able to get the solid red light to flash at all, despite unregistering the device from the app and removing power from the device three different times. I also moved my internet connection point to within 10ft of the device, outside, unobstructed, and still no change in LED status .

Update: This has now happened twice. I now have a permanent wifi extender within 10ft of the one cam I’ve installed so the signal to the cam is fine. Each time I trip the breaker to remove power from the unit when it stops making a connection to my network, this happens. I have also removed it from my eufysecurity app in attempts to do another fresh connection. Why is it taking literally days for the red light to start flashing red (or if it will at all, this time)?


again, after about 1-2 days, it started flashing red and i connected it to the network 10ft away. however, it never established an actual connection and always showed 0 b/s so playback was never established. I left it alone for half a day and when i came back, it was back to solid red and “floodlight cam is offline” on the app.

constant issues. no input from Eufy here???

1 Like

I have the same exact issue and couldn’t resolve it

hopefully we receive any response from Eufy

did anyone get this resolved? I have moved my camera to a new location on our house and originally i was going to send it back. Now it will not register. Need it done by tomorrow (Sunday lunch time) in the UK.

Thanks guys.