Eufy Doorbell is Offline and will not re-connect

My new Eufy doorbell was working fine after the initial install 2 days ago. This morning the doorbell is “offline” and will not reset. I’ve verify the internet signal, disconnected and re-connected the doorbell and all I get is the yellow pulsing circle, no doorbell, no connect. Can anyone suggest a solution?

Have you tried the “doorbell diagnosis” in the settings for the doorbell?

Thanks for responding TechMan. Is this setting for “doorbell diagnosis” on the App? I don’t see any doorbell diagnosis.

Yes, it’s in the app.

Go to the devices tab, than select the little gear in the corner of the doorbell widget. You should be able to scroll down and select device diagnosis

My smartphone (iphone 7S) will not accept the device for some reason or another. I’ve entered the code several times either by scanning and manually yet it does not recognize any devices. When I Add Device, enter code manually (verified twice by myself and my wife just to be sure), I go to the door bell, see the yellow pulsating circle, press it for a long time (like 10 seconds) and get NOTHING.

That’s really strange. Contact eufy support at

Anker has a great support team, so expect they’ll be able to help you out. Good luck!

Thanks, I’ve got an email into them already. No phone support on weekend. Have a great weekend

1 Like

I always feel that it’s the weekend when I have to contact support teams :joy:. I guess it’s my fate to have to wait the extra 2 days lol

Did you ever get a fix? I installed the doorbell today and it works, records, streams, etc. After a couple of hours it’s offline and pulsing yellow. I reset it once and could add it back to my network as a new doorbell but then it happened again a couple of hours later, if that.


Seems like we’re having the same issue. Doorbell worked fine for a little while, then we were getting nuisance hits so I toned it down one notch, then realized we weren’t getting any hits. It’s offline and I can’t get it to reconnect.

Same here. To say it is frustrating is an understatement. I tried connecting the doorbell to a wifi extender that is literally 8 ft. away and the same thing happens. The only way to get it back connected is to power cycle the doorbell by flipping the breaker or disconnect wires.

1 Like

I am having the same issue. Doorbell worked fine for several days, then went offline. Voltage was good and all connections were tight, but no light on the doorbell. It seemed to go offline overnight when the temperature dropped to 29 degrees F. I verified that the jumper connections were still tight, cycled power to doorbell and still no light. I had to reset the unit with the reset button on the back of the doorbell to get it to function again. I have the latest firmware as of 1/17/2020. I am waiting on a call from Eufy, but I think this one is going back to them. Doing weekly resets is just not an acceptable solution.

Tech support seems to think this is not an uncommon problem and that dismounting the doorbell and resetting it is an acceptable solution. If I had to pop the hood on my car to reset it’s computer once a month, I would be looking for another car!


I’ve had mine installed for maybe a month now and am having the same problem; constant disconnects. I then have to press and hold the button for 5 secs to get the amber light and restart it via the app. From there, it’s fine for an undetermined amount of time. Sometimes a couple days, sometimes a couple hours. Starting to feel like I should’ve kept my Ring doorbell.

1 Like

Any solution on this issue?. I have exactly the same problem and I’ve called customer support just to let me know that this issue is “rare” and I should sent it back for replacement

Has there been any resolution to this issue? I just had the same thing happen. Purchased a new 2k Doorbell, worked perfectly for 2 days, now won’t connect. Have even tried moving the homebase very close to the door. Very disappointing QA/QC for an expensive product.

1 Like

I’ve had mine for a week or so, it disconnects almost every day, I think it’s an ISP thing, the internet drops for about 30 seconds, when it comes back up, my wired doorbell is “Offline” and the only way to bring it back is to do the “hold the button for 5 sec. Thing” this is ridiculous, my $50 doorbell at the back door recovers in seconds, so do all my cameras, garage door opener and switches.
So if I’m on vacation or at work the doorbell is useless until I can manually reset it? That’s a joke no?
I’m disappointed, I really wanted to like this doorbell, but this is unacceptable.

I’ve got the same problem with mine. Worked fine for a few months but over past couple of weeks nothing. Wifi connects. Doorbell sound works. Diagnostic says it’s good. Reset from APP doesn’t connect. Disconnected Power and still nothing. I’ll try uninstall app and reinstall but this is ridiculous.

So this issue started happening to me on Day 2 and I have not found any remedy!

I was wondering if there was something in common with these issues!

  • I am using Verizon FIOS for my internet
  • I have a Netgear router

My router is less than 50 feet from the doorbell.

Did anyone solve the issue?
I have removed and re-added the device
I reset to default and re-added - with no help
I uninstalled the application and reinstalled - no luck
I tried an iphone in case that was the issue - no luck
I had even removed power and turned it back on. No luck.

I never found a solution.

I was so impressed how easy it was to install in my vacation property. Now I am beck home I have the same problem. It is of NO use to me if it requires resetting every few days.

same here, installed the doorbell three days ago and this morning it was …offline. If Eufy doesn’t offer a proper solution or if I cant find a solution that works for me I will sent it back immediately