Eufy can't go in straight lines

Hi, Any advice please, my eufy robovac won’t go on a straight line any more. I’ve cleaned everything I know how but no success on fixing this issue, does anyone have any tips for correction please

Hi @Julia_James, sorry to hear the Robovac is giving your trouble. If you have cleaned the sensors and tried the troubleshooting steps in the manual (such as restarting via power on/off) you would be best to contact for assistance with your fault.


Hi @Julia_James, as @ndalby suggested reach out to @AnkerSupport they will get you the help you need. When I had issues with my robovac they helped me get it sorted out. (They took care of my issues on the forums)


@Julia_James, sorry to hear your Robovac will not go in a straight line. Please be assured that we always stand behind with our products and will glad to help you replace or return it if the issue turns out to be with it.

We understand you have cleaned the Robovac, but could you please tap a little harder on the bumper and wheels to see whether they are stuck? And if necessary, remove any hair and debris from them.

If the issue persists, could you please contact us via our We will help you replace or return it once we confirmed the issue and your order detail.

We appreciate your time and looking forward your reply!

Having the same problem - only had my vacuum since April and it will not go straight at all

Sorry to hear that. Would you mind contacting directly? I’m sure our great customer service will help you out. :relaxed:

@ndalby @Will17 Did either of you find a way to resolve this issue? I talked to support and walked through all the steps to make sure my robovac was cleaned and up to par, but it is still going in crooked lines :smirk: They offered to replace it but wanted me to pay shipping for the new vacuum and for the return of my original. Disappointed. I loved my vacuum for the 2 weeks it worked properly.

Sucks to hear that

A post was merged into an existing topic: Spam Links / Accounts - ongoing