Eufy cam won’t charge

Hi there,

I’ve been using the eufy cam for about 4months with no issues have a 2 camera set up and recently charged the one camera by plugging it into the hub to recharge with no issues.
Have just repeated the process with the other camera but… the camera just will not charge. I’ve tried different cables from the one that worked on the other camera and still no good. Even tried plugging into a pc USB port and still no good. Any ideas?

Obviously you did all possible. and 4 month
the camera should be under warranty.
Contact the support!

You may want to try to go to the eufy community as well for solutions.

I have just recently got a eufy homebase and cameras. It may be too early for me to try to help. Was your plug seeded in the camera to keep it dry and away from moisture. If not I would say sit it near the heat vent to make sure it dries out. Other than that I would contact Eufy on any warrenty.

Hmm maybe the port is bad. Try to get it exchanged under warranty

i have same issue cam won’t charge,i using another cable work with another cam, still don’t change

Try using different cables and chargers. A USB port may be messing up for example

Clean and check the socket of your camera.
All the pins are in order?

Time to contact email and hopefully they can send you another unit or by refunding you