Eufy Cam E turned off notification

On my phone the app displaying devices shows one of my cameras “Camera has turned off due to low battery”
It’s been working flawlessly and was at 100% still this morning until now.
The funny thing is it is still recording and sending notifications for this camera even though it says it’s turned off. I have tried to refresh on screen under the notification with no luck. Camera settings show that the camera is on and when I turn it off and on, there no refresh of the display.
There was an update pushed out this morning.

1 Like

I am experiencing exact same issue with one of my cameras, I’ve mailed Eufy Tech Support, still waiting for response

Support had me remove the device and do a factory reset on the camera by holding camera’s sync button for about 10 seconds till it beeped twice. Tried adding it back with no luck, same condition. I spoke to them on phone and they will be replacing it.

I just tried that as well, also with no luck. I will charge the battery again and see if it works, then wait for their response.

Hello!@greg42 Sincerely apologize for all inconvenience caused! Could you please try contacting Our associated support staff will forward your issue to our engineer team for a further checking. Sincerely thank you for your valuable time!

Sent back on Monday, had a new cam on Thursday, all is good now.

Hello, I very recently started having this same problem with mine. ‘Camera has turned off due to low battery” Live view doesn’t work, but clips are still recording when motion is detected.

I tried charging it (for the first time after about a year) which appeared to charge with a blinking light, while charging, and then a steady light when done, but that didn’t get rid of the error, and the app shows no battery again. I also tried removing the camera, resetting to factory defaults and repairing with the base, which didn’t fix the problem. Clips are still recording, but no live view.

Does anyone know what the solution is to this problem?

1 Like

I’m still having the same problem. I started a support request Reference Ticket#91192132 but never heard back from anybody.