Eufy 30C will not turn on or charge

My Eufy 30C got trapped in the bathroom and completely ran out of charge. When I placed it on the charging station, it would not charge. I have checked to verify the power button is on, I have cleaned the charging heads, and unplugged and re-plugged in the charging station. Any other ideas?

Put it on the charging base a d leave it to charge, sometimes when something is fully dead it will need a bit before it will revive itself. So by leaving it to charge it can slowly build its charge back up so it can turn on and properly charge

It sat overnight on the charging station last night. This actually happened yesterday. So it was sitting for about 16 hrs. before I started to look at it again today.

Did it get wet at all? If you are within your 12 month warranty just reach out to

No, it did not get wet. Unfortunately purchased it Nov 28, 2018.

If your handy, open it up and unplug the battery for say 10 minutes and then plug it back in and see if it charges then

Last trick I would suggest, take off the batteries from the case at the bottom
and connect these after a while.
This is a hard reset, may be that could help.

This worked! Thank you so much!

1 Like

Glad it worked for ya. If you ever have any issues just ask as we are always here to help