Eufy 15c Max stopped connectiong to wifi

I bought a 15c Max on May 5th this year. It connected fine during the initial setup, flawlessly infact, but recently it wont reconnect.
I have a BT home hub dual band router. It has seperate 2.4GHz and 5GHz networks, my 15c connected to the 2.4GHz fine first time round! I have disabled the 5GHz network and it still wont connect.
Last night my internet went down, its back up now but since it went down it wont reconnect.
I have followed all that i can find on Google but I think something isn’t right.
I have done the following -

  1. force stopped the app (I have an s10+)
  2. turned off mobile data
  3. turned off bluetooth
  4. tried to pair away from router but with in range
  5. reset the 15c buy turning it off then holding down the power for 20 seconds so it slow flashes

When I get the device reset, so it slow flashes, this is what is happening -

  1. I use my phone app to try and reconnect
  2. I put in my wifi details
  3. It asks me to confirm its slow flashing

  4. I hit connect via the “+” button

  5. Then the 15c stops slow flashing and it fast flashes
  6. In the wifi settings it has connected to the vac (when it does this it stops slow flashing?)

It fails everytime.

Am I doing somthing wrong or has the vac stopped working as intended?

Many thanks

1 Like

This is really a question.
I am not used to WIFI-RoboVacs.
But as far I see you have quite done all which is possible.

You have to ask the support.

Did you change the password for your wifi network?

Thank you, i will but i didn’t know if any one had heard of this issue before.
Many thanks

No, it has had the same password from day one, I am loth to change it as my house has many “smart” products and i don’t want to have to re do them all, just for the VAC, I can always use the remote but that seems like a waste to me.
Many thanks

Hi @robert.a.macey
Looks like you’ve tried a ton of stuff.
Its still hard to day if its your home network or the Robovac.
Do you have other items connected and working over 2.4ghz?
Could you set up a different SSID and password to try.
Or maybe first do you have a neighbour you could visit to try and register on their network?
If its works with a neighbour it rules out the Robovac.

1 Like

I don’t have a robovac but I wonder if there is a way to reset them

i have many things connected to the 2.4ghz, smart switches/sockets, alexa, TVs etc
None of them have any issues reconnecting.
I can’t set up a new SSID, I don’t have the time or inclination to re set all my devices.
As for neighbours, I do not, the lady next door doesn’t have any internet… too old, and i don’t get on with the guy next door.
I do have a netgear network at the back of the house but i still can’t connect to that either.

1 Like
  1. Turn it off via the switch
  2. Turn it back on
  3. Hold down the power button for 10/20 seconds untill you get a beep and the wifi symbol slow flashes

Hey @robert.a.macey
Just a few thoughts. But to clarify i meant set up another SSID to run alongside the existing and just to see if the new one works with the Robovac.

So if you haven’t already, reach out direct to Eufy at
Or as its under warranty, get it back to the retailer for an exchange unit and see how that goes - that will identify if your unit is faulty or something amiss with your network.

unfortunately my router doesn’t allow me to set up another SSID :frowning:

1 Like

Thats a shame @robert.a.macey
Perhaps try the exchange/replacement route.
Don’t be a stranger, keep us updated how you proceed :+1:t2:

@robert.a.macey Try this and see if it works.

First on your phone navigate through Settings > Connections > Wi-Fi > 3 dot menu > Advanced > Manage Networks

Then find your vacuums network which should be listed towards the top. Hit delete, select the network, and delete again. If more than one vacuum network shows up, delete all of them.

Now reset the vacuum again by power cycling with the switch and holding the button.

Open the app and go through all the normal set-up procedures.

Hope this helps!

Hi, I have the same problem, same model. It worked fine for about a week but suddenly stopped to connect to the app. I have tried everything, I even bought a new router, but still doesn’t connect. I have an iPhone 11.